summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2017-01-26 13:48:37 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-27 00:19:57 +0100
commit8525dd46c17b5d9859d7bd2f3eebbf81f2b3f57b (patch)
treecd3c87cfbedba241626bc78d5c0892b5d26ae236 /lxde-base/lxappearance/lxappearance-0.6.3.ebuild
parentx11-wm/lumina: Adjusting i18n stuff (diff)
downloadgentoo-8525dd46c17b5d9859d7bd2f3eebbf81f2b3f57b.tar.gz
gentoo-8525dd46c17b5d9859d7bd2f3eebbf81f2b3f57b.tar.bz2
gentoo-8525dd46c17b5d9859d7bd2f3eebbf81f2b3f57b.zip
lxde-base/lxappearance: bump to 0.6.3
https://blog.lxde.org/category/lxtask/ Implemented search for RC files using standard GTK+ way (with environment variable GTK2_RC_FILES taken into consideration). Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3657
Diffstat (limited to 'lxde-base/lxappearance/lxappearance-0.6.3.ebuild')
-rw-r--r--lxde-base/lxappearance/lxappearance-0.6.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/lxde-base/lxappearance/lxappearance-0.6.3.ebuild b/lxde-base/lxappearance/lxappearance-0.6.3.ebuild
new file mode 100644
index 000000000000..8a6e29d18d54
--- /dev/null
+++ b/lxde-base/lxappearance/lxappearance-0.6.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="LXDE GTK+ theme switcher"
+HOMEPAGE="http://lxde.sourceforge.net"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="dbus"
+
+RDEPEND="x11-libs/gtk+:2
+ dbus? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_configure() {
+ econf \
+ $(use_enable dbus)
+}