summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-14 00:39:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-15 14:08:20 +0100
commit0f2fcbf47daca9429d209596806816b93e38ff63 (patch)
tree3da604bc7fb335b7bfddd6290a3e525b50d8af00 /lxde-base/lxappearance
parentmedia-plugins/kodi-pvr-hts: Cleanup old version (diff)
downloadgentoo-0f2fcbf47daca9429d209596806816b93e38ff63.tar.gz
gentoo-0f2fcbf47daca9429d209596806816b93e38ff63.tar.bz2
gentoo-0f2fcbf47daca9429d209596806816b93e38ff63.zip
lxde-base/lxappearance: EAPI-7 bump, switch to GTK3
Add missing dependencies Bug: https://bugs.gentoo.org/769524 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxde-base/lxappearance')
-rw-r--r--lxde-base/lxappearance/lxappearance-0.6.3-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/lxde-base/lxappearance/lxappearance-0.6.3-r2.ebuild b/lxde-base/lxappearance/lxappearance-0.6.3-r2.ebuild
new file mode 100644
index 000000000000..7871a1c7b61b
--- /dev/null
+++ b/lxde-base/lxappearance/lxappearance-0.6.3-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="LXDE GTK+ theme switcher"
+HOMEPAGE="https://wiki.lxde.org/en/LXAppearance"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ dbus? ( dev-libs/dbus-glib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --enable-gtk3 \
+ $(use_enable dbus)
+}