summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-27 21:48:13 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 01:28:30 +0200
commit7fb33666cef4ee07f5eb5e6f43c8fcc7bc1cc7bd (patch)
treeac9805cfb9b1ace276eb53747bc8a945454f9018 /lxqt-base/lxqt-openssh-askpass
parentlxqt-base/lxqt-notificationd: add version 0.15.0 (diff)
downloadgentoo-7fb33666cef4ee07f5eb5e6f43c8fcc7bc1cc7bd.tar.gz
gentoo-7fb33666cef4ee07f5eb5e6f43c8fcc7bc1cc7bd.tar.bz2
gentoo-7fb33666cef4ee07f5eb5e6f43c8fcc7bc1cc7bd.zip
lxqt-base/lxqt-openssh-askpass: add version 0.15.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-openssh-askpass')
-rw-r--r--lxqt-base/lxqt-openssh-askpass/Manifest1
-rw-r--r--lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.15.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-openssh-askpass/Manifest b/lxqt-base/lxqt-openssh-askpass/Manifest
index ca2d50291e64..bec8acf95042 100644
--- a/lxqt-base/lxqt-openssh-askpass/Manifest
+++ b/lxqt-base/lxqt-openssh-askpass/Manifest
@@ -1 +1,2 @@
DIST lxqt-openssh-askpass-0.14.1.tar.xz 16848 BLAKE2B b774027c878c75324a5908244ef2cf33b0a092cbd2c0801c92c1304a6eed40fc8a18919ac25c6632ba306bd7f56cfc64cf9880cf166639cf5a8eea4a1bfad66e SHA512 ab35cd719d4a31a495bed68a30cad5bf85701d223ee7306f0dad40717d0c2821af53e07a929b5855fb0cd680684fb790a638b59a1ea3ef288e0f656ab490b5bf
+DIST lxqt-openssh-askpass-0.15.0.tar.xz 17032 BLAKE2B 3a6e235477d3499429f854351f4f8686f6aaec2c8ee114fab32acd0a6759cc6e782c5afda7e1b0e496346673838938fa083322d4dc147380a918209f5c0ab0a6 SHA512 e9dd41dd75892be234e6381670fa0b836bf040b00b7c59c7f23cadc9a916e8c646c4d44645a49183a305c6b755a01e6b8e6a3c0f84aa7c374cdb3ddd577e2f44
diff --git a/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.15.0.ebuild b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.15.0.ebuild
new file mode 100644
index 000000000000..00da38eed188
--- /dev/null
+++ b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.15.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt OpenSSH user password prompt tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+
+ newenvd - 99${PN} <<- _EOF_
+ SSH_ASKPASS='${EPREFIX}/usr/bin/lxqt-openssh-askpass'
+ _EOF_
+}