summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-11-05 22:37:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 08:11:33 +0100
commit20f6a9c16ce225f16a3650212f0654f8f3485c7f (patch)
tree7cbe2ddbd3713fe8878ad94d07fb67112aeb49fb /lxqt-base
parentlxqt-base/lxqt-notificationd: add version 0.16.0 (diff)
downloadgentoo-20f6a9c16ce225f16a3650212f0654f8f3485c7f.tar.gz
gentoo-20f6a9c16ce225f16a3650212f0654f8f3485c7f.tar.bz2
gentoo-20f6a9c16ce225f16a3650212f0654f8f3485c7f.zip
lxqt-base/lxqt-policykit: add version 0.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-policykit/Manifest1
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-0.16.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/Manifest b/lxqt-base/lxqt-policykit/Manifest
index 883837bb7f81..70f34ce2f83a 100644
--- a/lxqt-base/lxqt-policykit/Manifest
+++ b/lxqt-base/lxqt-policykit/Manifest
@@ -1 +1,2 @@
DIST lxqt-policykit-0.15.0.tar.xz 37712 BLAKE2B b9263234766dd9a2e89288f6668e8553e1f5deae0e306443fc3d15268f3fbbb4b9cfb81987d1e1f9c96ece4494ef700a6e40bf5e498eeb3d7377f3848d09b376 SHA512 2dbbe6d626ef5da816f080354caf564a1aa58270ae299483b9a4ce35d5f1bdb3c652dcb5f12d2668a0ea82556414b00320d2bd88fcadb37fbbdbf724a17e3c41
+DIST lxqt-policykit-0.16.0.tar.xz 38016 BLAKE2B dd077f1a25b9bb5ee56f7ad08f24254936f3b5f1b6ab4c9148ebce160867b8535341353339470d4363fbb52eead522133ed702f7d98b78cc08df58eeb5d6467b SHA512 f6eae925cbf25064addf5d89999d16a7397ddb0d8c616f75a3b81df57a42a70e52da599fdad6b8589a1e951cf46cd541e9a23e352a0d2ee309116b6e0238cfa9
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-0.16.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-0.16.0.ebuild
new file mode 100644
index 000000000000..1b2e1ddccccf
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-0.16.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ sys-auth/polkit-qt[qt5(+)]
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}