summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-27 02:30:53 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-27 02:30:53 +0200
commit48af2857b1396846bd6f1859b9aedd9fb741ea1e (patch)
tree4f4939715225d043a90a0c698b2dc793d03e402d /lxqt-base
parentlxqt-base/lxqt-powermanagement: Version bump to 0.11.0 (diff)
downloadgentoo-48af2857b1396846bd6f1859b9aedd9fb741ea1e.tar.gz
gentoo-48af2857b1396846bd6f1859b9aedd9fb741ea1e.tar.bz2
gentoo-48af2857b1396846bd6f1859b9aedd9fb741ea1e.zip
lxqt-base/lxqt-admin: Version bump to 0.11.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-admin/Manifest1
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-0.11.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/Manifest b/lxqt-base/lxqt-admin/Manifest
index feb115dc0769..450fcc9dd95d 100644
--- a/lxqt-base/lxqt-admin/Manifest
+++ b/lxqt-base/lxqt-admin/Manifest
@@ -1 +1,2 @@
DIST lxqt-admin-0.10.0.tar.xz 29364 SHA256 46a5dd35e4bb560643647dfc9439f4a6ba1cdb3fd73af639cb3aca364cd3a895 SHA512 a39e32c647f4d81e594dc1aa8c3792b62909b6209c7ae0452a26b21b1b5e733aa79d5d4489fd72e701e54d41b96be6fea683e991777179425c76516210f0d684 WHIRLPOOL 0f6b72875bfcdee552ad239392956ba314e95833445d0b8229b6abecf77e33d737eb3057d4d620f4bbc16f9641b587f880bbf2e1b0b7d67b106fd42789eadb6d
+DIST lxqt-admin-0.11.0.tar.xz 114720 SHA256 34eb3a5cd93d10b1440b0a098b21d5bc512f76dc03ab36dfd78c57e9cb9da6a2 SHA512 cbbd83892c0c181eb996de198f6c5d3b00d0c6a5e185b816ac1237bd5930da0aa8cd272696571bb91d70054e89ea96f4dd9b3aa34dff7534286ff3e529757792 WHIRLPOOL 452e71b07afcb536ba0fe0cb3649a10b28422f9e23338bc18607645b9e0687f27047486870c4cb1891e853504dbcf04fba4428fc3d1f8cf02c40a3217d8f4f53
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-0.11.0.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-0.11.0.ebuild
new file mode 100644
index 000000000000..c55c32bebf29
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-0.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND="dev-libs/glib:2
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ kde-frameworks/kwindowsystem:5
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}