summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-11-05 23:17:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 08:11:36 +0100
commit9ded63cf151b4630e3f010684eb60a41b883daf1 (patch)
tree307fb7cb46806cdade1c062c0c9567175da1bfbf /lxqt-base
parentlxqt-base/lxqt-about: add version 0.16.0 (diff)
downloadgentoo-9ded63cf151b4630e3f010684eb60a41b883daf1.tar.gz
gentoo-9ded63cf151b4630e3f010684eb60a41b883daf1.tar.bz2
gentoo-9ded63cf151b4630e3f010684eb60a41b883daf1.zip
lxqt-base/lxqt-runner: add version 0.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-runner/Manifest1
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-0.16.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-runner/Manifest b/lxqt-base/lxqt-runner/Manifest
index 9f21f631f291..059d4cd6941a 100644
--- a/lxqt-base/lxqt-runner/Manifest
+++ b/lxqt-base/lxqt-runner/Manifest
@@ -1 +1,2 @@
DIST lxqt-runner-0.15.0.tar.xz 223996 BLAKE2B 90e078d4a2cb93bfc9f964cf4cdcee73e4d5a390ec1383f623b96f15646dec7cff630d95dcd3613427063213c951325826c69d5bff6ee8b9b3024133ed01166c SHA512 559a5ef627f311ee4894891445a7f1bf70349d7f89ec3eb1d5550f8e87486d695d03fb70a8ec936b074e83c82c29ff26c07ee3edeebbbf8dade2d9a5f4dacdba
+DIST lxqt-runner-0.16.0.tar.xz 224496 BLAKE2B e5e2802eb9d90a28720137cba205b662000f8ce0ec9f1e7c9b2c3053b12a966c7a16e2d89526f82fe60ca80df38418fe6b5a5ff75a946eae833af7219b908dd4 SHA512 ae7aa1a8e6dbc3dbb464ce2812820eab98f073dacfc4195fb54adae10d69bdaaf25f852d1955c785075c31a8c75bfe42fa2456bc366c8293f0b94eff53c59c88
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-0.16.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-0.16.0.ebuild
new file mode 100644
index 000000000000..e95b697efa46
--- /dev/null
+++ b/lxqt-base/lxqt-runner/lxqt-runner-0.16.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt quick launcher"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)*"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-cpp/muParser-2.2.3:=
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}
+ =lxqt-base/lxqt-globalkeys-${MY_PV}
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}