summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-16 19:54:08 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-18 08:00:34 +0300
commitbe32b39850c00101b34e8ef8dcf2d6cc7e39bb48 (patch)
treeacf96e0357ee109a0d0e49f8882f79fdc3b63908 /lxqt-base
parentlxqt-base/lxqt-powermanagement: add version 0.17.0 (diff)
downloadgentoo-be32b39850c00101b34e8ef8dcf2d6cc7e39bb48.tar.gz
gentoo-be32b39850c00101b34e8ef8dcf2d6cc7e39bb48.tar.bz2
gentoo-be32b39850c00101b34e8ef8dcf2d6cc7e39bb48.zip
lxqt-base/lxqt-panel: add version 0.17.1
This switches the default state for the USE-flags 'statusnotifier' and 'tray' according to upstream preference ('tray' is deprecated). Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-panel/Manifest1
-rw-r--r--lxqt-base/lxqt-panel/lxqt-panel-0.17.1.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-panel/Manifest b/lxqt-base/lxqt-panel/Manifest
index 30f7e74384cd..8b52ac704162 100644
--- a/lxqt-base/lxqt-panel/Manifest
+++ b/lxqt-base/lxqt-panel/Manifest
@@ -1 +1,2 @@
DIST lxqt-panel-0.16.1.tar.xz 473632 BLAKE2B aee19df3cef9dd25b20ae44cdbeb0c017fefc1e7e7f1d350e07820aa2d873a03dfd69a990e99abed95a9c633a6c496bff356fbbcfcc3cebacc50dde52dc79780 SHA512 2db8c4b5d8ddf42b72ffd5863242774277b4bf2fd1ec4393908851ce3224c970de5f12ae61be3dd7008407ea5df7b0b59990b03982e2725ee9a0ce2e3cce48f5
+DIST lxqt-panel-0.17.1.tar.xz 510212 BLAKE2B fec84d1758ba1824c5c77ba730040e2d662f97c08b48378acc2efff53237cb993d1543918429224be1e5ba539a8de96b91f3a9ba4e1095fa69fe3c72e26d5156 SHA512 439905144029518e46efdd72eb3db17203678e243ca5f7090bf5db902805deaded41f6c59d02bf538fbf24b7951d6da6a924331c685b69d162812249fb9a4e72
diff --git a/lxqt-base/lxqt-panel/lxqt-panel-0.17.1.ebuild b/lxqt-base/lxqt-panel/lxqt-panel-0.17.1.ebuild
new file mode 100644
index 000000000000..8a566cd13e37
--- /dev/null
+++ b/lxqt-base/lxqt-panel/lxqt-panel-0.17.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt desktop panel and plugins"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)*"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+IUSE="+alsa colorpicker cpuload +desktopswitch +directorymenu dom +kbindicator
++mainmenu +mount networkmonitor pulseaudio +quicklaunch lm-sensors +showdesktop
++spacer +statusnotifier sysstat +taskbar tray +volume +worldclock"
+
+# Work around a missing header issue: https://bugs.gentoo.org/666278
+REQUIRED_USE="
+ || ( desktopswitch mainmenu showdesktop taskbar )
+ volume? ( || ( alsa pulseaudio ) )
+"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5[X]
+ >=lxde-base/lxmenu-data-0.1.5
+ >=lxde-base/menu-cache-1.1.0
+ =lxqt-base/liblxqt-${MY_PV}
+ =lxqt-base/lxqt-globalkeys-${MY_PV}
+ x11-libs/libX11
+ cpuload? ( sys-libs/libstatgrab )
+ kbindicator? ( x11-libs/libxkbcommon )
+ lm-sensors? ( sys-apps/lm-sensors )
+ mount? ( kde-frameworks/solid:5 )
+ networkmonitor? ( sys-libs/libstatgrab )
+ statusnotifier? ( dev-libs/libdbusmenu-qt[qt5(+)] )
+ sysstat? ( >=lxqt-base/libsysstat-0.4.1 )
+ tray? (
+ x11-libs/libxcb:=
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXrender
+ x11-libs/xcb-util
+ )
+ volume? (
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ media-sound/pavucontrol-qt
+ media-sound/pulseaudio
+ )
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ # Plugins
+ -DCOLORPICKER_PLUGIN=$(usex colorpicker)
+ -DCPULOAD_PLUGIN=$(usex cpuload)
+ -DDESKTOPSWITCH_PLUGIN=$(usex desktopswitch)
+ -DDIRECTORYMENU_PLUGIN=$(usex directorymenu)
+ -DDOM_PLUGIN=$(usex dom)
+ -DKBINDICATOR_PLUGIN=$(usex kbindicator)
+ -DMAINMENU_PLUGIN=$(usex mainmenu)
+ -DMOUNT_PLUGIN=$(usex mount)
+ -DNETWORKMONITOR_PLUGIN=$(usex networkmonitor)
+ -DQUICKLAUNCH_PLUGIN=$(usex quicklaunch)
+ -DSENSORS_PLUGIN=$(usex lm-sensors)
+ -DSHOWDESKTOP_PLUGIN=$(usex showdesktop)
+ -DSPACER_PLUGIN=$(usex spacer)
+ -DSTATUSNOTIFIER_PLUGIN=$(usex statusnotifier)
+ -DSYSSTAT_PLUGIN=$(usex sysstat)
+ -DTASKBAR_PLUGIN=$(usex taskbar)
+ -DTRAY_PLUGIN=$(usex tray)
+ -DVOLUME_PLUGIN=$(usex volume)
+ -DWORLDCLOCK_PLUGIN=$(usex worldclock)
+ )
+
+ if use volume; then
+ mycmakeargs+=(
+ -DVOLUME_USE_ALSA=$(usex alsa)
+ -DVOLUME_USE_PULSEAUDIO=$(usex pulseaudio)
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ doman panel/man/*.1
+}