summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2019-03-27 10:33:01 +0100
committerMichał Górny <mgorny@gentoo.org>2019-07-05 12:47:23 +0200
commit713b872dd7a981692b1c8d8ca776068cbfbdd9a2 (patch)
tree5ae2c11057fdc45d8c41940b60638736c12a5f0a /mail-client/alot
parentdev-java/json: Fix LICENSE. (diff)
downloadgentoo-713b872dd7a981692b1c8d8ca776068cbfbdd9a2.tar.gz
gentoo-713b872dd7a981692b1c8d8ca776068cbfbdd9a2.tar.bz2
gentoo-713b872dd7a981692b1c8d8ca776068cbfbdd9a2.zip
mail-client/alot: Add version bump to 0.8.1
Closes: https://bugs.gentoo.org/681842 Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'mail-client/alot')
-rw-r--r--mail-client/alot/Manifest1
-rw-r--r--mail-client/alot/alot-0.8.1.ebuild81
-rw-r--r--mail-client/alot/files/0.8.1-0001-remove-non-working-test.patch31
3 files changed, 113 insertions, 0 deletions
diff --git a/mail-client/alot/Manifest b/mail-client/alot/Manifest
index ebf3ec61eb1d..791931f3a5d2 100644
--- a/mail-client/alot/Manifest
+++ b/mail-client/alot/Manifest
@@ -2,3 +2,4 @@ DIST alot-0.3.7.tar.gz 1475759 BLAKE2B d14ba03f86dfb04f16644f27286e6a7314d0559b3
DIST alot-0.5.1.tar.gz 1490645 BLAKE2B fd63ff7191fba3ee7fa3cf362cad9d684513fd6180263a2b888ee2cc00d55ca5442e273ed1b4e4012106db67404715eff4302ea25b89343ca0f467953402de33 SHA512 0194f163724fc5485aa89fe5354d16bdfdd3f539f6f3cfdb715e61835f3e632b8ac0daed44983a95c20eb0244c44c1d7801d262a5fd16ad63c3efd046e05b787
DIST alot-0.6.tar.gz 1527183 BLAKE2B 60e06d806bf5bfacdec485c3bcde6a5473bce2093abcc20d5e105b40f6d78bf93773c3b54311fdbbb632abe724a410d8941cfb0018842ee445ccea64c73a5033 SHA512 300b99d4919dd59d569de49195e33a3224bc28fbddf0b2aa6e3b419e030a22ec2d9acf389d67eb062cad9f2cd85f019cd6dff23e724491718e246397e70ed059
DIST alot-0.7.tar.gz 1539283 BLAKE2B 33e77f815c4f83fc08f1834a89a984309c1d4b89454d9bb0df625d00725c64769ce4989fa8df8f38d40d1c35fb78202880fedc0a0a5e7134f1938a03c79e7721 SHA512 542827c94e6cfc57699613b352527582dc2e365d957ba6b7e835584e8b83d0704452acd5ab8e4e1e408c283ec3400a8bbe465b2a8fad9f95fb330328c4fe81f8
+DIST alot-0.8.1.tar.gz 220342 BLAKE2B 019f41f1f1fe73aa17a309a73b12883cbbae6a232d912d0e328b3862fc4e8e49ea6a3d0b6e2921ecb4d6ee8a58a9f6826facd7ff4cd6fafc17f6f5fe0195dd2c SHA512 bca4a01636594f0e71c6ea260d74cf26e74dfd7aca1ea7801714b4aaf9602ae7737769e77e3af0363ed2701df1494e0f87ce85b58c47a6380ad1a9098f8501d4
diff --git a/mail-client/alot/alot-0.8.1.ebuild b/mail-client/alot/alot-0.8.1.ebuild
new file mode 100644
index 000000000000..87ddb352ed6c
--- /dev/null
+++ b/mail-client/alot/alot-0.8.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="https://github.com/pazz/alot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=app-crypt/gpgme-1.9.0[python,${PYTHON_USEDEP}]
+ >=dev-python/configobj-4.7.0[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/urwidtrees-1.0[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ net-mail/mailbase
+ >=net-mail/notmuch-0.27[crypt,python]
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PV}-0001-remove-non-working-test.patch"
+ )
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+src_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/alot
+ doins -r extra
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog ""
+ elog "If you are new to Alot you may want to take a look at"
+ elog "the user manual:"
+ elog " https://alot.readthedocs.io/en/latest/"
+ elog ""
+ else
+ local rv
+ for rv in ${REPLACING_VERSIONS} ; do
+ if ver_test "${rv}" -le "0.5.1"; then
+ ewarn ""
+ ewarn "Since 0.6 version the GPG engine has switched to app-crypt/gpgme"
+ ewarn "to use GPG signing operations, you can pass the key id has arg"
+ ewarn "or setup the gpg_key value in your config file, see"
+ ewarn " https://alot.readthedocs.io/en/latest/usage/crypto.html?highlight=gpg"
+ ewarn ""
+ break
+ fi
+ done
+ fi
+}
diff --git a/mail-client/alot/files/0.8.1-0001-remove-non-working-test.patch b/mail-client/alot/files/0.8.1-0001-remove-non-working-test.patch
new file mode 100644
index 000000000000..489c54d9bd44
--- /dev/null
+++ b/mail-client/alot/files/0.8.1-0001-remove-non-working-test.patch
@@ -0,0 +1,31 @@
+From f83bc02ff427508d69ffccb908fd2eaa5a7144c1 Mon Sep 17 00:00:00 2001
+From: Guillaume Seren <guillaumeseren@gmail.com>
+Date: Fri, 3 May 2019 18:17:05 +0200
+Subject: [PATCH] Remove non working test
+
+Some test are not working
+---
+ tests/commands/test_global.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/tests/commands/test_global.py b/tests/commands/test_global.py
+index 9b026e6a..727a4d41 100644
+--- a/tests/commands/test_global.py
++++ b/tests/commands/test_global.py
+@@ -166,13 +166,6 @@ class TestExternalCommand(unittest.TestCase):
+ await cmd.apply(ui)
+ ui.notify.assert_not_called()
+
+- @utilities.async_test
+- async def test_no_spawn_no_stdin_attached(self):
+- ui = utilities.make_ui()
+- cmd = g_commands.ExternalCommand(u'test -t 0', refocus=False)
+- await cmd.apply(ui)
+- ui.notify.assert_not_called()
+-
+ @utilities.async_test
+ async def test_no_spawn_stdin_attached(self):
+ ui = utilities.make_ui()
+--
+2.21.0
+