summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2019-03-17 20:51:13 -0400
committerSobhan Mohammadpour <sobhan@gentoo.org>2019-03-17 20:56:23 -0400
commita3d48af3594483cd40de0bce6dad3729bbf485eb (patch)
tree59755fe41fa73c61d07c3d21f134d7a02213cae2 /mail-client/geary
parentnet-misc/putty: Fix Manifest? (diff)
downloadgentoo-a3d48af3594483cd40de0bce6dad3729bbf485eb.tar.gz
gentoo-a3d48af3594483cd40de0bce6dad3729bbf485eb.tar.bz2
gentoo-a3d48af3594483cd40de0bce6dad3729bbf485eb.zip
mail-client/geary: bump from 0.12 → 3.32.0
Major bumped, add as masked changed build system to meson, call xdg stuff, removed deps that are no longer needed and an unwind use flag, mask will be removed after some testing Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
Diffstat (limited to 'mail-client/geary')
-rw-r--r--mail-client/geary/Manifest1
-rw-r--r--mail-client/geary/geary-3.32.0.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/mail-client/geary/Manifest b/mail-client/geary/Manifest
index 7fb1662e9a0c..a10a0b3fe9d7 100644
--- a/mail-client/geary/Manifest
+++ b/mail-client/geary/Manifest
@@ -1 +1,2 @@
DIST geary-0.12.4.tar.xz 1070368 BLAKE2B 7d4c07184cd99ed507839e3f2c53171bf75809e76ef92283a15d93bd3f074ed700f6db2de14263bf8f7c060526023a81e9123433cf11a353c68497a3b70e2bdd SHA512 5bf05390e06ecd7e3b3de35fcfa068e5ad475f1e4f67c4b2ff65d9f8162759cccc1aa47f0ed9c3a0a8d68059fa404d4360e019ac42cdfc86a8258790f0a6df7c
+DIST geary-3.32.0.tar.xz 2228056 BLAKE2B b9ee9e48fb901aa8fe8ef291b8332ac222d7581d1700170aa605071698ea0d8b698511c6e372c9a5056c3d7bf4885ec84aa389f7558fdd00cb4eeb43d745ee39 SHA512 eec6a552fe87c74d364d7242631f6ddfb6cfe35dc4f634ec7aa80342f9e02439255a2a4b12b0f88ee6369962058bbbdc64c390189bd6480a225685ad52cb68f8
diff --git a/mail-client/geary/geary-3.32.0.ebuild b/mail-client/geary/geary-3.32.0.ebuild
new file mode 100644
index 000000000000..44c256f2c5a5
--- /dev/null
+++ b/mail-client/geary/geary-3.32.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A lightweight, easy-to-use, feature-rich email client"
+HOMEPAGE="https://wiki.gnome.org/Apps/Geary"
+
+LICENSE="LGPL-2.1+ BSD-2 CC-BY-3.0 CC-BY-SA-3.0" # code is LGPL-2.1+, BSD-2 for bundled snowball-stemmer, CC licenses for some icons
+SLOT="0"
+
+IUSE="unwind"
+
+KEYWORDS="~amd64"
+
+# for now both enchants work
+# FIXME: add valadoc support
+
+DEPEND="
+ >=dev-libs/glib-2.54:2
+ >=x11-libs/gtk+-3.22.26:3[introspection]
+ >=net-libs/webkit-gtk-2.20:4=[introspection]
+ app-text/iso-codes
+ >=dev-db/sqlite-3.12:3
+
+ >=net-libs/libsoup-2.48:2.4[introspection]
+ net-libs/gnome-online-accounts
+
+ >=dev-libs/libgee-0.8.5:0.8=[introspection]
+ >=x11-libs/libnotify-0.7.5[introspection]
+ >=media-libs/libcanberra-0.28
+ >=dev-libs/gmime-2.6.17:2.6
+ >=app-crypt/libsecret-0.11[introspection,vala]
+ >=dev-libs/libxml2-2.7.8:2
+ >=app-crypt/gcr-3.10.1:0=[gtk,introspection,vala]
+ app-text/enchant
+ >=dev-libs/folks-0.11:0
+ dev-libs/json-glib
+ >=sys-libs/libunwind-1.1:7
+"
+RDEPEND="${DEPEND}
+ gnome-base/dconf
+ gnome-base/gsettings-desktop-schemas
+"
+# org.gnome.desktop.interface clock-format global setting usage
+# gnome-doc-utils for xml2po for TRANSLATE_HELP option
+DEPEND="${DEPEND}
+ sys-devel/gettext
+ dev-util/desktop-file-utils
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ local i
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd po ; echo *.po) ; do
+ if ! has ${i%.po} ${LINGUAS} ; then
+ sed -i -e "/^${i%.po}$/d" po/LINGUAS || die
+ fi
+ done
+ fi
+
+ meson_src_prepare
+ gnome2_src_prepare
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ # appstream_util & desktop_file_validate doesn't seem to
+ # doing anything useful for an actual release, maybe for 9999?
+ local emesonargs=(
+ -Dlibunwind_optional=$(usex unwind false true)
+ -Dpoodle=true
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}