summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/novell-groupwise-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/novell-groupwise-client')
-rw-r--r--mail-client/novell-groupwise-client/Manifest1
-rw-r--r--mail-client/novell-groupwise-client/metadata.xml7
-rw-r--r--mail-client/novell-groupwise-client/novell-groupwise-client-8.0.2.96933.ebuild75
3 files changed, 83 insertions, 0 deletions
diff --git a/mail-client/novell-groupwise-client/Manifest b/mail-client/novell-groupwise-client/Manifest
new file mode 100644
index 000000000000..f82b86611e6a
--- /dev/null
+++ b/mail-client/novell-groupwise-client/Manifest
@@ -0,0 +1 @@
+DIST gw802_hp3_client_linux_multi.tar.gz 209918505 SHA256 f9be044980dd00703aaf2a1b2b93468e526a308cfe91769a61c7079ec3e08f98 SHA512 3a03ac02954f86c2e797404128441bff980f82cdc9936668fb528aef0190240891f92e4094fe53d58a0684ef8e94ebac7c73fbfa262e72bc450fab8ea9872efd WHIRLPOOL a07c30b18f6902521fe07d60b1ead302dc669a19c3d31e1af5acf91185b581924bd2ccfc07216a00ac06e7451aa981ac88958719d59a51b5a9053a445f455ad5
diff --git a/mail-client/novell-groupwise-client/metadata.xml b/mail-client/novell-groupwise-client/metadata.xml
new file mode 100644
index 000000000000..606b5ed6bb4d
--- /dev/null
+++ b/mail-client/novell-groupwise-client/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dilfridge@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/mail-client/novell-groupwise-client/novell-groupwise-client-8.0.2.96933.ebuild b/mail-client/novell-groupwise-client/novell-groupwise-client-8.0.2.96933.ebuild
new file mode 100644
index 000000000000..4bb1beb4fe93
--- /dev/null
+++ b/mail-client/novell-groupwise-client/novell-groupwise-client-8.0.2.96933.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils rpm multilib versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+MY_P="${P/_p/-}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Novell Groupwise Client for Linux"
+HOMEPAGE="http://www.novell.com/products/groupwise/"
+SRC_URI="gw802_hp3_client_linux_multi.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ sys-libs/libstdc++-v3
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.8[abi_x86_32(-)]
+ >=x11-libs/libXcursor-1.1.14[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.3[abi_x86_32(-)]
+ >=x11-libs/libXfixes-5.0.1[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.4[abi_x86_32(-)]
+ >=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
+ >=x11-libs/libXtst-1.2.2[abi_x86_32(-)]
+ >=x11-libs/libxcb-1.11-r1[abi_x86_32(-)]
+ x11-libs/motif:2.2[abi_x86_32(-)]
+ >=media-libs/alsa-lib-1.0.28[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.5[abi_x86_32(-)]
+"
+
+RESTRICT="binchecks fetch mirror strip"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}"/${PN}-${MY_PV} || die
+ cd ${PN}-${MY_PV} || die
+ rpm_unpack ./../gw${MY_PV}_client_linux_multi/${PN}-${MY_PV}.i586.rpm
+}
+
+src_compile() { :; }
+
+src_install() {
+ JRE_DIR="${WORKDIR}"/${PN}-${MY_PV}/opt/novell/groupwise/client/java;
+
+ # Undo Sun's funny-business with packed .jar's
+ for i in $JRE_DIR/lib/*.pack; do
+ i_b=`echo $i | sed 's/\.pack$//'`;
+ einfo "Unpacking `basename $i` -> `basename $i_b.jar`";
+ $JRE_DIR/bin/unpack200 $i $i_b.jar || die "Unpack failed";
+ done;
+
+ domenu "${WORKDIR}"/${PN}-${MY_PV}/opt/novell/groupwise/client/gwclient.desktop
+
+ mv "${WORKDIR}"/${PN}-${MY_PV}/opt "${D}"/ || die "mv opt failed"
+
+ dodir /opt/bin
+ dosym /opt/novell/groupwise/client/bin/groupwise /opt/bin/groupwise
+}
+
+pkg_nofetch() {
+ einfo "You can obtain an evaluation version of the Groupwise client at"
+ einfo "${HOMEPAGE} - please download ${SRC_URI}"
+ einfo "and place it in ${DISTDIR}. Alternatively request the file"
+ einfo "from the Groupwise server provider of your organization."
+ einfo "Note that the client is useless without a server account."
+}