summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-25 00:54:01 -0400
committerTim Harder <radhermit@gentoo.org>2015-08-25 00:54:07 -0400
commit2fa70c200ea1504af7d0e7d9be66d2329ffb3aac (patch)
tree21ad5dd5c1413807b5f435293c8ac7e90d4380d7 /mail-client/roundcube
parentsys-fs/s3ql: version bump (diff)
downloadgentoo-2fa70c200ea1504af7d0e7d9be66d2329ffb3aac.tar.gz
gentoo-2fa70c200ea1504af7d0e7d9be66d2329ffb3aac.tar.bz2
gentoo-2fa70c200ea1504af7d0e7d9be66d2329ffb3aac.zip
mail-client/roundcube: security bump to 1.0.6 (bug #554866)
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.0.6.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 423f64f582da..1875e64e8c52 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1 +1,2 @@
DIST roundcubemail-1.0.5.tar.gz 4056852 SHA256 22af84480f2c543884b17c9b0196ed105d2ea7f429bfcc34a6fb7c96dd712792 SHA512 28016a8b05bdf4777486c63d95a91a22022006252e61e4e93320d81448cbc630ed5a04a1388d8576a40617d8e0630b90290341fcd3fed4f5080ab250fb568c6c WHIRLPOOL f0e48173e0fe07a8f3a00a49ad1091c33f76dbeb153941e32c35684f4eb41e04f805f63ec9623e3664c165c6e88407db3665f1e60a01c2076a3c60bc96c4a122
+DIST roundcubemail-1.0.6.tar.gz 4057804 SHA256 76e600183c91fa598823bb97208f81485c73f354ea05f4e82d56e91003e0df49 SHA512 1aa2f652fe88c3fa22d1181105733a6bf0bdd5439b7abc051a4b00030310c923936487e6aa5d5f62179fae010c79b818d6b5e37afca749dcf1738be8930c7709 WHIRLPOOL e9581f4707daf1bdf9c11316ed60e457a367ba94ff46b92e72fea38eec09df86858f5af55ce4626016fe54552dbea155466fed62fe5a27539b46e89d1714f9b4
diff --git a/mail-client/roundcube/roundcube-1.0.6.ebuild b/mail-client/roundcube/roundcube-1.0.6.ebuild
new file mode 100644
index 000000000000..7a6ff2467684
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.0.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_P=${MY_PN}-${PV/_/-}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap +mysql postgres sqlite ssl spell"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.3[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,ssl?,unicode,xml]
+ >=dev-php/PEAR-Auth_SASL-1.0.3
+ >=dev-php/PEAR-Crypt_GPG-1.3.2
+ >=dev-php/PEAR-Mail_Mime-1.8.1
+ >=dev-php/PEAR-Net_IDNA2-0.1.1
+ >=dev-php/PEAR-Net_SMTP-1.4.2
+ >=dev-php/PEAR-Net_Sieve-1.3.2
+ >=dev-php/PEAR-Net_Socket-1.0.14
+ mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
+ spell? ( dev-lang/php[curl,spell] )
+ sqlite? ( dev-lang/php[sqlite] )
+ virtual/httpd-php
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Remove bundled PEAR packages
+ rm -r program/lib/{Auth,Crypt,Mail,Net,PEAR*} || die
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "When upgrading from <= 0.9, note that the old configuration files"
+ ewarn "named main.inc.php and db.inc.php are deprecated and should be"
+ ewarn "replaced with one single config.inc.php file."
+ ewarn "Run the ./bin/update.sh script to convert those"
+ ewarn "or manually merge the files."
+ ewarn "The new config.inc.php should only contain options that"
+ ewarn "differ from the ones listed in defaults.inc.php."
+}