summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-10-16 08:46:58 -0400
committerCraig Andrews <candrews@gentoo.org>2023-10-16 08:47:51 -0400
commit18eeabae13a935659563f4f82dfc67122d29b77c (patch)
tree95b2ef8e0ae1613e09ed780507548034852501cf /mail-client
parentnet-libs/nghttp3: drop 0.11.0, 0.12.0, 0.13.0, 0.14.0, 0.15.0 (diff)
downloadgentoo-18eeabae13a935659563f4f82dfc67122d29b77c.tar.gz
gentoo-18eeabae13a935659563f4f82dfc67122d29b77c.tar.bz2
gentoo-18eeabae13a935659563f4f82dfc67122d29b77c.zip
mail-client/roundcube: add 1.6.4
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.6.4.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index b9fd520b2b41..6da585e9b5f2 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -3,3 +3,4 @@ DIST roundcubemail-1.5.4-complete.tar.gz 7891674 BLAKE2B 898173304fb1a2618062f3c
DIST roundcubemail-1.6.1-complete.tar.gz 5970713 BLAKE2B b46545b4a26983fbb993550e2c2f1504aea26c2caba28eb86703c6a94ac61209fecf45041b07440a495b7d2ad58eb20cb688cf37718402ef409ccc5442f0f62e SHA512 d5804e91c2da3b732cf14ad86f06099254540dd826ae5b7f14b98a7af8b90a7e9457221da2945aace8d12a60381eec85161e8bc6e0af4572b798a66cb36f2f00
DIST roundcubemail-1.6.2-complete.tar.gz 6004046 BLAKE2B 08e6b93cdb615ac2555dcf8a23317ac5be96c3ef2dd2a53b44992e04d17591fcbb16fa0e21cb22e92c3ccdc82c7da817cdb4f95c208476bcdd5d81b9d0fecc12 SHA512 1889548dbe9913555cec4115137157de9daf5e2cca9e4004fb19c8ddebd3081cce32b6d8634891341c890379c4f9e35a5c705739f24b0b3b93fc31449f090297
DIST roundcubemail-1.6.3-complete.tar.gz 6026670 BLAKE2B f3108c5040a912ffdca83a08c2768224a1edd197abca8c9420985d6c241dd93c56e1ed6ee05ede4c385ed6fbb6f2e780e1914b54504cb19d46e14df419001f4f SHA512 9a44a898f8ed9a338f126af19b572b61a7b108412be5f0c445f6ff3d84636a1487cc594347629a757e2fa18fdfa2881c3dd373e2431132a906799992c935b548
+DIST roundcubemail-1.6.4-complete.tar.gz 6027429 BLAKE2B f83ee7662dfa6a27e6aae97f90e1af80fa5d68927a0336dd3dab84f438e88921cb60059d41256daa52eac44fff07673559a21c860b01ebc82747fe021b2fadda SHA512 ccfd6828ed0f9a25c3144133a9a0f091b7ef76251e74422fe90dc1eb6fdddee8522902869d97609cd594f0977ecb6eb7402378d390ae33d907d154a24a607f85
diff --git a/mail-client/roundcube/roundcube-1.6.4.ebuild b/mail-client/roundcube/roundcube-1.6.4.ebuild
new file mode 100644
index 000000000000..190b5fa07b04
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.6.4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+
+IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-7.4.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
+ EGIT_BRANCH="master"
+ BDEPEND="${BDEPEND}
+ app-arch/unzip
+ dev-php/composer
+ net-misc/curl"
+else
+ SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ pushd "${S}" > /dev/null || die
+ rm Makefile || die
+ mv composer.json-dist composer.json || die
+ composer install --no-dev || die
+ ./bin/install-jsdeps.sh || die
+ popd > /dev/null || die
+ else
+ default
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}