summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-09-16 12:33:40 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-09-16 12:34:21 +0300
commit2b34111aa5099e78aa73a9fd574255c090d02700 (patch)
tree9139cc959f03eb489e18ae316e3feeed9f2cc732 /mail-client
parentwww-client/firefox: add a rust version check to 102 (diff)
downloadgentoo-2b34111aa5099e78aa73a9fd574255c090d02700.tar.gz
gentoo-2b34111aa5099e78aa73a9fd574255c090d02700.tar.bz2
gentoo-2b34111aa5099e78aa73a9fd574255c090d02700.zip
mail-client/thunderbird: add a rust version check to 102
- apparently it's easier to have two different rust versions installed than I had thought. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-102.2.2-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/mail-client/thunderbird/thunderbird-102.2.2-r1.ebuild b/mail-client/thunderbird/thunderbird-102.2.2-r1.ebuild
index b9386e16e062..8de2284563ba 100644
--- a/mail-client/thunderbird/thunderbird-102.2.2-r1.ebuild
+++ b/mail-client/thunderbird/thunderbird-102.2.2-r1.ebuild
@@ -416,6 +416,13 @@ pkg_setup() {
fi
fi
+ if ver_test $(rustc -V | cut -d" " -f2) -ge "1.63"; then
+ ewarn "Rust-1.63 is currently unsupported for building Thunderbird-102."
+ ewarn "Please use 'eselect rust' to switch to a lower version, then resume"
+ ewarn "building Thunderbird."
+ die "Rust-1.63 detected. Use eselect rust to choose <1.63"
+ fi
+
python-any-r1_pkg_setup
# Avoid PGO profiling problems due to enviroment leakage