summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2017-11-08 19:59:38 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-03 13:55:37 +0100
commit7f07c91fbd9d9c66a5236f495ebcf911923fbf9c (patch)
tree0e3d217b33c6c0fd33f402f65c9477d7bb501273 /mail-client
parentprofiles: Drop obsolete USE kde masks (diff)
downloadgentoo-7f07c91fbd9d9c66a5236f495ebcf911923fbf9c.tar.gz
gentoo-7f07c91fbd9d9c66a5236f495ebcf911923fbf9c.tar.bz2
gentoo-7f07c91fbd9d9c66a5236f495ebcf911923fbf9c.zip
mail-client/alot: version bump to 0.6.
This version migrate from using dev-python-pygpgme, to app-crypt/gpgme with the python USE flag. Closes: https://bugs.gentoo.org/636804 Closes: https://github.com/gentoo/gentoo/pull/6153 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alot/Manifest3
-rw-r--r--mail-client/alot/alot-0.6.ebuild88
2 files changed, 90 insertions, 1 deletions
diff --git a/mail-client/alot/Manifest b/mail-client/alot/Manifest
index 388e3b7cca16..c5494e87f7db 100644
--- a/mail-client/alot/Manifest
+++ b/mail-client/alot/Manifest
@@ -1,2 +1,3 @@
DIST alot-0.3.7.tar.gz 1475759 SHA256 fe281f6b5fbfcd371a1810c8f59084e8cbc3f69068269e3f787adb1df6f977b5 SHA512 a0b7e5a7b77f8cdee38c273eec2822bee2e7c409ab4b8803817a49d679dd53ff29750ba7f8a9214368cc7b0b17bd76a40b0263b4701b2ef695c7669316b1b116 WHIRLPOOL 3c37a037fc5543ff569f6a5364302462f71f5599c14d17661707cd4beb0e2a8597098dd4f4a42aec27793ace7095bba4eb80c35ed5fd8e470f6b7b9dbbecc46e
-DIST alot-0.5.1.tar.gz 1490645 SHA256 e8404db01bfe41030f7df9f559ac6c61edc473bfc1ae86bcb58c4018703352c7 SHA512 0194f163724fc5485aa89fe5354d16bdfdd3f539f6f3cfdb715e61835f3e632b8ac0daed44983a95c20eb0244c44c1d7801d262a5fd16ad63c3efd046e05b787 WHIRLPOOL 2539956ab4f286c0db27837f5897f3dd8868c07422aca2845df76da8d0c2aa3b5915ec8de0b35d78f8f296406adb6d31c4d47b00c2c74a7453630e936d4aee98
+DIST alot-0.5.1.tar.gz 1490645 BLAKE2B fd63ff7191fba3ee7fa3cf362cad9d684513fd6180263a2b888ee2cc00d55ca5442e273ed1b4e4012106db67404715eff4302ea25b89343ca0f467953402de33 SHA512 0194f163724fc5485aa89fe5354d16bdfdd3f539f6f3cfdb715e61835f3e632b8ac0daed44983a95c20eb0244c44c1d7801d262a5fd16ad63c3efd046e05b787
+DIST alot-0.6.tar.gz 1527183 BLAKE2B 60e06d806bf5bfacdec485c3bcde6a5473bce2093abcc20d5e105b40f6d78bf93773c3b54311fdbbb632abe724a410d8941cfb0018842ee445ccea64c73a5033 SHA512 300b99d4919dd59d569de49195e33a3224bc28fbddf0b2aa6e3b419e030a22ec2d9acf389d67eb062cad9f2cd85f019cd6dff23e724491718e246397e70ed059
diff --git a/mail-client/alot/alot-0.6.ebuild b/mail-client/alot/alot-0.6.ebuild
new file mode 100644
index 000000000000..10d2659af187
--- /dev/null
+++ b/mail-client/alot/alot-0.6.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="https://github.com/pazz/alot/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/configobj-4.7.0[${PYTHON_USEDEP}]
+ >=app-crypt/gpgme-1.9.0[python,${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-10.2.0[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/urwidtrees-1.0[${PYTHON_USEDEP}]
+ net-mail/mailbase
+ >=net-mail/notmuch-0.13[crypt,python]
+ "
+
+python_prepare_all() {
+ find "${S}" -name '*.py' -exec sed -e '1i# -*- coding: utf-8 -*-' -i '{}' +
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/alot
+ doins -r extra
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ echo
+ elog "If you are new to Alot you may want to take a look at"
+ elog "the user manual:"
+ elog " https://alot.readthedocs.io/en/latest/"
+ echo
+ else
+ local rv
+ for rv in ${REPLACING_VERSIONS} ; do
+ if [[ "0.3.2" == "${rv}" ]]; then
+ ewarn ""
+ ewarn "The syntax of theme-files and custom tags-sections of the config"
+ ewarn "has been changed. You have to revise your config. There are"
+ ewarn "converter scripts in /usr/share/alot/extra to help you out with"
+ ewarn "this:"
+ ewarn ""
+ ewarn " * tagsections_convert.py for your ~/.config/alot/config"
+ ewarn " * theme_convert.py to update your custom theme files"
+ break;
+ fi
+ if [[ "0.5.1" == "${rv}" ]]; then
+ ewarn ""
+ ewarn "Since 0.6 version the GPG engine has switched to app-crypt/gpgme"
+ ewarn "to use GPG signing operations, you can pass the key id has arg"
+ ewarn "or setup the gpg_key value in your config file, see"
+ ewarn " https://alot.readthedocs.io/en/latest/usage/crypto.html?highlight=gpg"
+ ewarn ""
+ break;
+ fi
+ done
+ fi
+}