summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/anubis/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/anubis/files')
-rw-r--r--mail-filter/anubis/files/4.1.1-gnutls.patch11
-rw-r--r--mail-filter/anubis/files/4.1.1-gnutls3.patch14
-rw-r--r--mail-filter/anubis/files/4.1.1-gpgme.patch32
-rw-r--r--mail-filter/anubis/files/4.1.1-testsuite.patch14
4 files changed, 71 insertions, 0 deletions
diff --git a/mail-filter/anubis/files/4.1.1-gnutls.patch b/mail-filter/anubis/files/4.1.1-gnutls.patch
new file mode 100644
index 000000000000..c4dd28bff693
--- /dev/null
+++ b/mail-filter/anubis/files/4.1.1-gnutls.patch
@@ -0,0 +1,11 @@
+--- configure.ac 2011-06-13 13:46:22.817856139 +0300
++++ configure.ac 2011-06-13 13:47:56.000000000 +0300
+@@ -277,7 +277,7 @@
+ if test $with_gnutls = yes; then
+ AC_CHECK_HEADERS(gnutls/gnutls.h)
+ if test $ac_cv_header_gnutls_gnutls_h != no; then
+- AM_PATH_LIBGNUTLS("1.0.0",
++ PKG_CHECK_MODULES(LIBGNUTLS, gnutls >= 1.0.0,
+ [M4_DEFS="$M4_DEFS -DWITH_SSL -DWITH_GNUTLS"
+ AC_DEFINE(USE_GNUTLS, 1,
+ [Define to 1 if USE_GNUTLS is requested.])],
diff --git a/mail-filter/anubis/files/4.1.1-gnutls3.patch b/mail-filter/anubis/files/4.1.1-gnutls3.patch
new file mode 100644
index 000000000000..c9d9197a2184
--- /dev/null
+++ b/mail-filter/anubis/files/4.1.1-gnutls3.patch
@@ -0,0 +1,14 @@
+--- src/tls.c 2008-12-16 16:21:54.000000000 +0000
++++ src/tls.c 2012-10-30 09:06:37.387243098 +0000
+@@ -294,7 +294,10 @@
+ static void
+ verify_certificate (gnutls_session session)
+ {
+- int status = gnutls_certificate_verify_peers (session);
++ int status, verify_ret;
++ verify_ret = gnutls_certificate_verify_peers2 (session, &status);
++ if (!verify_ret)
++ return status;
+
+ if (status == GNUTLS_E_NO_CERTIFICATE_FOUND)
+ {
diff --git a/mail-filter/anubis/files/4.1.1-gpgme.patch b/mail-filter/anubis/files/4.1.1-gpgme.patch
new file mode 100644
index 000000000000..7aa8ba578eec
--- /dev/null
+++ b/mail-filter/anubis/files/4.1.1-gpgme.patch
@@ -0,0 +1,32 @@
+--- configure.ac 2011-06-13 19:40:37.856822010 +0300
++++ configure.ac 2011-06-13 19:43:27.000000000 +0300
+@@ -149,10 +149,18 @@
+ AC_MSG_CHECKING(for $1/include/gpgme.h)
+ AC_MSG_RESULT([yes])
+ return 0
++ else
++ if test -f "$1/include/gpgme/gpgme.h"; then
++ gpgmedir=1
++ INCLUDES="$INCLUDES -I$1/include/gpgme"
++ AC_MSG_CHECKING(for $1/include/gpgme/gpgme.h)
++ AC_MSG_RESULT([yes])
++ return 0
++ fi
+ fi
+ return 1
+ }
+- for maindir in /usr/pkg /opt /sw; do
++ for maindir in /usr/pkg /opt /sw /usr; do
+ findgpgmedir $maindir && break 2
+ done
+ if test $gpgmedir; then
+--- configure.ac 2011-06-17 11:54:29.000000000 +0000
++++ configure.ac 2011-06-17 11:56:22.000000000 +0000
+@@ -137,6 +137,7 @@
+ else
+ AM_PATH_GPGME([1.0.0], with_gpgme=yes, with_gpgme=no)
+ AC_CHECK_LIB(gpgme, main,, with_gpgme=no)
++ AC_CHECK_LIB(gpg-error, gpg_err_init,, with_gpgme=no)
+ fi
+ if test "$with_gpgme" = "no"; then
+ AC_MSG_RESULT([Disabling GPGME support...])
diff --git a/mail-filter/anubis/files/4.1.1-testsuite.patch b/mail-filter/anubis/files/4.1.1-testsuite.patch
new file mode 100644
index 000000000000..5b1c656fa0af
--- /dev/null
+++ b/mail-filter/anubis/files/4.1.1-testsuite.patch
@@ -0,0 +1,14 @@
+--- testsuite/data/Makefile.am 2011-06-13 14:29:38.843665225 +0300
++++ testsuite/data/Makefile.am 2011-06-13 14:31:16.000000000 +0300
+@@ -22,8 +22,10 @@
+ EXTRA_DIST = pubring.asc secring.asc anubis.pem append.txt users
+ CLEANFILES = *.gpg random_seed *~ text.db
+
+-pubring.gpg secring.gpg: $(srcdir)/pubring.asc $(srcdir)/secring.asc
++pubring.gpg: $(srcdir)/pubring.asc
+ $(GPG) --homedir . --import < $(srcdir)/pubring.asc
++
++secring.gpg: $(srcdir)/secring.asc
+ $(GPG) --homedir . --allow-secret-key-import --import < $(srcdir)/secring.asc
+
+ text.db: $(srcdir)/users