summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/clamsmtp/clamsmtp-1.10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/clamsmtp/clamsmtp-1.10.ebuild')
-rw-r--r--mail-filter/clamsmtp/clamsmtp-1.10.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/mail-filter/clamsmtp/clamsmtp-1.10.ebuild b/mail-filter/clamsmtp/clamsmtp-1.10.ebuild
new file mode 100644
index 000000000000..7107d9fe1c11
--- /dev/null
+++ b/mail-filter/clamsmtp/clamsmtp-1.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="ClamSMTP is an SMTP filter that allows you to check for viruses using the ClamAV anti-virus software"
+HOMEPAGE="http://memberwebs.com/nielsen/software/clamsmtp/"
+
+SRC_URI="http://memberwebs.com/nielsen/software/clamsmtp/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa ~sparc x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=">=app-antivirus/clamav-0.75"
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README NEWS
+ newinitd "${FILESDIR}"/clamsmtpd.init clamsmtpd
+ insinto /etc
+ newins doc/clamsmtpd.conf clamsmtpd.conf
+
+ sed -i \
+ -e "s|\#\(ClamAddress\): .*|\1: /var/run/clamav/clamd.sock|" \
+ -e "s|\#\(User\): .*|\1: clamav|" \
+ "${D}"/etc/clamsmtpd.conf
+}
+
+pkg_postinst() {
+ echo
+ elog "For help configuring Postfix to use clamsmtpd, see:"
+ elog " http://memberwebs.com/nielsen/software/clamsmtp/postfix.html"
+ echo
+ ewarn "You'll need to have ScanMail support turned on in clamav.conf"
+ ewarn "Also, make sure the clamd scanning daemon is running (not just freshclam)"
+ echo
+}