summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/libsrs_alt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/libsrs_alt')
-rw-r--r--mail-filter/libsrs_alt/Manifest1
-rw-r--r--mail-filter/libsrs_alt/files/libsrs_alt-1.0-ftime.patch12
-rw-r--r--mail-filter/libsrs_alt/libsrs_alt-1.0.ebuild44
-rw-r--r--mail-filter/libsrs_alt/metadata.xml11
4 files changed, 68 insertions, 0 deletions
diff --git a/mail-filter/libsrs_alt/Manifest b/mail-filter/libsrs_alt/Manifest
new file mode 100644
index 000000000000..b4b73c572799
--- /dev/null
+++ b/mail-filter/libsrs_alt/Manifest
@@ -0,0 +1 @@
+DIST libsrs_alt-1.0.tar.gz 337225 SHA256 97ee41246f55cb59b24a5b5ccb16af83b036e54502b1f9360a7f912866fba41e
diff --git a/mail-filter/libsrs_alt/files/libsrs_alt-1.0-ftime.patch b/mail-filter/libsrs_alt/files/libsrs_alt-1.0-ftime.patch
new file mode 100644
index 000000000000..290c90d6c5d9
--- /dev/null
+++ b/mail-filter/libsrs_alt/files/libsrs_alt-1.0-ftime.patch
@@ -0,0 +1,12 @@
+diff --git a/configure.ac b/configure.ac
+index 5a43896..d0e106c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,6 +31,7 @@ AC_FUNC_FORK
+ AC_TYPE_SIGNAL
+ AC_FUNC_STRNLEN
+ AC_CHECK_LIB(socket, bind)
++AC_CHECK_LIB(compat, ftime)
+ AC_CHECK_FUNCS([ftime memset socket strchr strdup strncasecmp])
+ AC_TYPE_SIZE_T
+
diff --git a/mail-filter/libsrs_alt/libsrs_alt-1.0.ebuild b/mail-filter/libsrs_alt/libsrs_alt-1.0.ebuild
new file mode 100644
index 000000000000..7077e5fe131c
--- /dev/null
+++ b/mail-filter/libsrs_alt/libsrs_alt-1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+MY_PV=${PV}
+MY_RC=${PV}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="Sender Rewriting Scheme library"
+HOMEPAGE="http://srs.mirtol.com/"
+SRC_URI="http://srs.mirtol.com/libsrs_alt-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!dev-perl/Mail-SRS"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-ftime.patch
+ eautoreconf
+}
+
+src_compile() {
+ # add missing header
+ sed -i -e '/timeb.h>/ a #include <stdlib.h>' test.c
+
+ # Since the primary intended consumers of this library are MTAs,
+ # use non-standard separator characters (--with-base64compat).
+ # This breaks "SRS Compliancy", which is a rough standard at
+ # best.
+ econf --with-base64compat || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc "${S}"/MTAs/README.EXIM
+}
diff --git a/mail-filter/libsrs_alt/metadata.xml b/mail-filter/libsrs_alt/metadata.xml
new file mode 100644
index 000000000000..0064ac998f52
--- /dev/null
+++ b/mail-filter/libsrs_alt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<longdescription>
+This is a complete standalone C implementation of the SRS (Sender Rewriting
+Scheme) and includes a command line utility and daemon, test utility and static
+and dynamic libraries. SRS is a stop-gap for users of SPF (Sender Policy
+Framework).
+</longdescription>
+</pkgmetadata>