summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-09-23 22:29:18 +0800
committerIan Delaney <idella4@gentoo.org>2015-09-23 22:29:51 +0800
commitc8244c3de06e6a1b6ba8d3d179b1f77d39fce964 (patch)
tree01eb0cd0182758bfbc0c11d88968ddc9ed89c3e9 /mail-filter/postgrey/postgrey-1.35-r2.ebuild
parentmedia-video/ffmpeg: Add rubberband useflag. (diff)
downloadgentoo-c8244c3de06e6a1b6ba8d3d179b1f77d39fce964.tar.gz
gentoo-c8244c3de06e6a1b6ba8d3d179b1f77d39fce964.tar.bz2
gentoo-c8244c3de06e6a1b6ba8d3d179b1f77d39fce964.zip
mail-filter/postgrey: revbump to 1.35-r2
Inherit systemd eclass, add service for systemd, rm old versions, ack to Stefan G. Weichinger for submitting service file, fixes Bug 528032 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'mail-filter/postgrey/postgrey-1.35-r2.ebuild')
-rw-r--r--mail-filter/postgrey/postgrey-1.35-r2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/mail-filter/postgrey/postgrey-1.35-r2.ebuild b/mail-filter/postgrey/postgrey-1.35-r2.ebuild
new file mode 100644
index 000000000000..9a4ec78592ef
--- /dev/null
+++ b/mail-filter/postgrey/postgrey-1.35-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd user
+
+DESCRIPTION="Postgrey is a Postfix policy server implementing greylisting"
+HOMEPAGE="http://postgrey.schweikert.ch/"
+SRC_URI="http://postgrey.schweikert.ch/pub/${P}.tar.gz
+http://postgrey.schweikert.ch/pub/old/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="targrey"
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.6.0
+ dev-perl/net-server
+ dev-perl/IO-Multiplex
+ dev-perl/BerkeleyDB
+ dev-perl/Net-DNS
+ dev-perl/Parse-Syslog
+ dev-perl/Net-RBLClient
+ virtual/perl-Digest-SHA
+ >=sys-libs/db-4.1"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_prepare() {
+ if use targrey ; then
+ epatch "${FILESDIR}"/targrey-0.31-postgrey-1.34.patch
+ fi
+ # bug 479400
+ sed -i 's@#!/usr/bin/perl -T -w@#!/usr/bin/perl -w@' postgrey || die "sed failed"
+}
+
+src_install() {
+ # postgrey data/DB in /var
+ diropts -m0770 -o ${PN} -g ${PN}
+ dodir /var/spool/postfix/${PN}
+ keepdir /var/spool/postfix/${PN}
+ fowners postgrey:postgrey /var/spool/postfix/${PN}
+ fperms 0770 /var/spool/postfix/${PN}
+
+ # postgrey binary
+ dosbin ${PN}
+ dosbin contrib/postgreyreport
+
+ # policy-test script
+ dosbin policy-test
+
+ # postgrey data in /etc/postfix
+ insinto /etc/postfix
+ insopts -o root -g ${PN} -m 0640
+ doins postgrey_whitelist_clients postgrey_whitelist_recipients
+
+ # documentation
+ dodoc Changes README README.exim
+
+ # init.d + conf.d files
+ insopts -o root -g root -m 755
+ newinitd "${FILESDIR}"/${PN}-1.34-r3.rc.new ${PN}
+ insopts -o root -g root -m 640
+ newconfd "${FILESDIR}"/${PN}.conf.new ${PN}
+ systemd_dounit "${FILESDIR}"/postgrey.service
+}