summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/rblcheck
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/rblcheck')
-rw-r--r--mail-filter/rblcheck/Manifest1
-rw-r--r--mail-filter/rblcheck/files/rblcheck-1.5-configure.patch20
-rw-r--r--mail-filter/rblcheck/metadata.xml8
-rw-r--r--mail-filter/rblcheck/rblcheck-1.5-r1.ebuild30
-rw-r--r--mail-filter/rblcheck/rblcheck-1.5-r2.ebuild30
5 files changed, 89 insertions, 0 deletions
diff --git a/mail-filter/rblcheck/Manifest b/mail-filter/rblcheck/Manifest
new file mode 100644
index 000000000000..e423fe813d16
--- /dev/null
+++ b/mail-filter/rblcheck/Manifest
@@ -0,0 +1 @@
+DIST rblcheck-1.5.tar.gz 150395 SHA256 c0f28cb0ec215ce2244e2a2008dac76bb6426adf0804f53c6784e6baeec13a47 SHA512 f0122701b5f7b293cf97cfb6f04963fdf657774f97342ecd57bc4a049b08f3d5b94e5148a4cc1f24de62c852b003c7339c35e4ddc199ea6be6a13583ca58f311 WHIRLPOOL 66ac047fb5c2ca7238e1fd7ad147039d55ec5560980ebf753148ef73f3a6231c497760af651fb9aa246691bf0c8b32af40665f5c99e57c911b8113d0909c551e
diff --git a/mail-filter/rblcheck/files/rblcheck-1.5-configure.patch b/mail-filter/rblcheck/files/rblcheck-1.5-configure.patch
new file mode 100644
index 000000000000..f21f0dfa4a6a
--- /dev/null
+++ b/mail-filter/rblcheck/files/rblcheck-1.5-configure.patch
@@ -0,0 +1,20 @@
+--- rblcheck-1.5/configure 2005-07-01 10:50:36.000000000 +0100
++++ rblcheck-1.5/configure 2005-07-01 10:57:05.000000000 +0100
+@@ -1529,13 +1529,12 @@
+ cat > conftest.$ac_ext <<EOF
+ #line 1531 "configure"
+ #include "confdefs.h"
+-/* Override any gcc2 internal prototype to avoid an error. */
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char res_query();
++
++/* Include <resolv.h> to get macro definition for res_query */
++#include <resolv.h>
+
+ int main() {
+-res_query()
++res_query("",0,0,"",0)
+ ; return 0; }
+ EOF
+ if { (eval echo configure:1542: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
diff --git a/mail-filter/rblcheck/metadata.xml b/mail-filter/rblcheck/metadata.xml
new file mode 100644
index 000000000000..d2a53afd5dd9
--- /dev/null
+++ b/mail-filter/rblcheck/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="sourceforge">rblcheck</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/mail-filter/rblcheck/rblcheck-1.5-r1.ebuild b/mail-filter/rblcheck/rblcheck-1.5-r1.ebuild
new file mode 100644
index 000000000000..841a35b8f2d6
--- /dev/null
+++ b/mail-filter/rblcheck/rblcheck-1.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Perform lookups in RBL-styles services"
+HOMEPAGE="http://rblcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rblcheck/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha ~amd64 hppa ~mips ppc sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-configure.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin rbl rblcheck
+
+ dodoc README docs/rblcheck.ps docs/rblcheck.rtf
+}
diff --git a/mail-filter/rblcheck/rblcheck-1.5-r2.ebuild b/mail-filter/rblcheck/rblcheck-1.5-r2.ebuild
new file mode 100644
index 000000000000..552cc40662bc
--- /dev/null
+++ b/mail-filter/rblcheck/rblcheck-1.5-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Perform lookups in RBL-styles services"
+HOMEPAGE="http://rblcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rblcheck/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-configure.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin rbl rblcheck
+
+ dodoc README docs/rblcheck.ps docs/rblcheck.rtf
+}