summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-05-25 21:24:02 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-05-26 09:31:17 -0400
commit630c791092d66bf1a72c7cf097bbca140efc77f1 (patch)
treebc8862de5743eaea9cc99fb7891526c06f8452ab /mail-filter/spf-engine
parentmail-filter/pypolicyd-spf: hard-code PN before a pkgmove. (diff)
downloadgentoo-630c791092d66bf1a72c7cf097bbca140efc77f1.tar.gz
gentoo-630c791092d66bf1a72c7cf097bbca140efc77f1.tar.bz2
gentoo-630c791092d66bf1a72c7cf097bbca140efc77f1.zip
mail-filter/pypolicyd-spf: rename to mail-filter/spf-engine.
Perform the "git mv", add the profiles/updates entry, rename the existing ebuild, and update metadata.xml. Bug: https://bugs.gentoo.org/724526 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'mail-filter/spf-engine')
-rw-r--r--mail-filter/spf-engine/Manifest1
-rw-r--r--mail-filter/spf-engine/metadata.xml11
-rw-r--r--mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild48
3 files changed, 60 insertions, 0 deletions
diff --git a/mail-filter/spf-engine/Manifest b/mail-filter/spf-engine/Manifest
new file mode 100644
index 000000000000..a02a604de1fa
--- /dev/null
+++ b/mail-filter/spf-engine/Manifest
@@ -0,0 +1 @@
+DIST pypolicyd-spf-2.0.2.tar.gz 38546 BLAKE2B 691cd5db37592be0ef0cda41223280e764e83802e37563f4e6c08505731118199c03d27b0bf51cec0556aa946fc6c7465fe09d3c9100c8e2582a4d85ad828495 SHA512 adcc7b30c6922894f9407edd0637b02a138623f4480ec37635475396826b457c835b3ffb599d1985e306770fe5f72404552ed705bd957e63b5c54ca3d8991673
diff --git a/mail-filter/spf-engine/metadata.xml b/mail-filter/spf-engine/metadata.xml
new file mode 100644
index 000000000000..9d7516779a0b
--- /dev/null
+++ b/mail-filter/spf-engine/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">spf-engine</remote-id>
+ <remote-id type="pypi">spf-engine</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild b/mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..da8cc8d6ff55
--- /dev/null
+++ b/mail-filter/spf-engine/spf-engine-2.0.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+# The built-in ipaddress module handles the parsing of IP addresses. If
+# python is built without ipv6 support, then ipaddress can't parse ipv6
+# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
+# other words, it's completely broken.
+PYTHON_REQ_USE="ipv6"
+
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+OLD_PN="pypolicyd-spf"
+OLD_P="${OLD_PN}-${PV}"
+OLD_PF="${PN}-${PVR}"
+DESCRIPTION="Python-based policy daemon for Postfix SPF verification"
+HOMEPAGE="https://launchpad.net/pypolicyd-spf"
+SRC_URI="mirror://pypi/p/${OLD_PN}/${OLD_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pyspf[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/authres[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${OLD_P}"
+
+DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
+
+python_prepare_all() {
+ # The "real" config file mentions the commented one, so we point
+ # users in the right direction.
+ local oldconf="policyd-spf.conf.commented"
+ local newconf="/usr/share/doc/${OLD_PF}/${oldconf}"
+
+ sed -i "1 s~ ${oldconf}~,\n# ${newconf}~" policyd-spf.conf \
+ || die 'failed to update commented config file path'
+
+ distutils-r1_python_prepare_all
+}