summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-16 21:53:34 +0000
committerSam James <sam@gentoo.org>2020-09-16 21:53:43 +0000
commit4940211893ecb31cf4057477e01cb28e391be129 (patch)
tree29ce7ad7d46f2077cda9cf8c9f85aaf49d86bf6a /mail-filter
parentmail-filter/mapson: port to EAPI 7 (diff)
downloadgentoo-4940211893ecb31cf4057477e01cb28e391be129.tar.gz
gentoo-4940211893ecb31cf4057477e01cb28e391be129.tar.bz2
gentoo-4940211893ecb31cf4057477e01cb28e391be129.zip
mail-filter/mapson: bump to 3.3.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/mapson/Manifest1
-rw-r--r--mail-filter/mapson/mapson-3.3.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/mail-filter/mapson/Manifest b/mail-filter/mapson/Manifest
index 77ada6c52e03..0bbcc99dc50c 100644
--- a/mail-filter/mapson/Manifest
+++ b/mail-filter/mapson/Manifest
@@ -1 +1,2 @@
+DIST mapson-3.3.1.tar.gz 553101 BLAKE2B 5100029e4b650b63cf868de48d9c709ac9fa8dcf773adb9ab70061756604116d69a20421d96ca769e19047efbe806cfc63432269cc83133f7f7f54f71b627d45 SHA512 07ecfdd2f9857a8b3818d065e4c342fda5089b77074ea153f9a380fe655716a214ff06f79eebe768b2470724e11a6ee819c1e457a47670c07537d6fd226dc1db
DIST mapson-3.3.tar.gz 421820 BLAKE2B e12c358113452a426cd5b55b945b77a303b595362064f6c84fe8bd8799502dd72872ca46cf54ce04022c3d27be52a849e337ae149521ce6ca35e990be73c1e98 SHA512 208d3b21d59689465a5c46619a53b3342c3ca96575d681b9ad01b1b6ffa05f05f56ab6e7ae38a8b2161e3f8d42b90b559baf8ff9db4ab4c83238d7adcb645fd0
diff --git a/mail-filter/mapson/mapson-3.3.1.ebuild b/mail-filter/mapson/mapson-3.3.1.ebuild
new file mode 100644
index 000000000000..4735517e167c
--- /dev/null
+++ b/mail-filter/mapson/mapson-3.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A challenge/response-based white-list spam filter"
+HOMEPAGE="http://mapson.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mapson/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="
+ acct-user/mail
+ virtual/mta
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3-respect-AR.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with debug)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ dodoc AUTHORS INSTALL NEWS README
+ doman doc/mapson.1
+
+ docinto html
+ dodoc doc/mapson.html
+
+ insinto /etc/mapson
+ newins sample-config mapson.config
+
+ insinto /usr/share/mapson
+ newins sample-challenge-template challenge-template
+
+ rm -f "${ED}"/etc/sample-config || die
+ rm -f "${ED}"/usr/share/{mapson.html,sample-challenge-template} || die
+}