summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-05-06 11:16:14 +0200
committerHanno Böck <hanno@gentoo.org>2020-05-06 11:16:14 +0200
commit5c2689c715c375e8805f14a5252301d3cfaa711d (patch)
treec423907e6b2beb5d2ee88fa512620ffe650b6f09 /mail-filter
parentdev-php/pecl-redis: amd64 stable wrt bug #721122 (diff)
downloadgentoo-5c2689c715c375e8805f14a5252301d3cfaa711d.tar.gz
gentoo-5c2689c715c375e8805f14a5252301d3cfaa711d.tar.bz2
gentoo-5c2689c715c375e8805f14a5252301d3cfaa711d.zip
mail-filter/zdkimfilter: Version bump
Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/zdkimfilter/Manifest1
-rw-r--r--mail-filter/zdkimfilter/zdkimfilter-2.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/mail-filter/zdkimfilter/Manifest b/mail-filter/zdkimfilter/Manifest
index 9a97e398ef13..0379a3343a58 100644
--- a/mail-filter/zdkimfilter/Manifest
+++ b/mail-filter/zdkimfilter/Manifest
@@ -1 +1,2 @@
DIST zdkimfilter-1.8.tar.gz 717481 BLAKE2B ec662a02c4a248085a42548d892084eb23c592c0511026039d18e8cc7a1a46dcf37411f8fc7395be507065ddb9cda8c5a1226e5e379852b4ef7ee84c2936b439 SHA512 e4b32c5d636db8a76ecfc2e4c8b1bda2053dc6c5baba13ed66120458f012a9d22d9ec269ae88100f1cc048b9c7d6c67a887ed1a48435a6353ab68bc13054c42c
+DIST zdkimfilter-2.1.tar.gz 737474 BLAKE2B a36155eef3bc31ede1446244f920040f1885109deae5646379f66a1a41315ad7f90552b64f138a61c4d88c0f616e2524fd8911302fd301503e70443948a68a34 SHA512 493a53d0879c7516196df32e364bf94d4f7f5265095637417ca9e569145dea68e528debe93f0835ffac493f05ab38d2b4cbd2bcd7da8029f5a9ef98a488d058d
diff --git a/mail-filter/zdkimfilter/zdkimfilter-2.1.ebuild b/mail-filter/zdkimfilter/zdkimfilter-2.1.ebuild
new file mode 100644
index 000000000000..870512573928
--- /dev/null
+++ b/mail-filter/zdkimfilter/zdkimfilter-2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DESCRIPTION="DKIM filter for Courier-MTA"
+HOMEPAGE="https://www.tana.it/sw/zdkimfilter"
+SRC_URI="https://www.tana.it/sw/zdkimfilter/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="mail-filter/opendkim
+ mail-mta/courier
+ dev-db/opendbx
+ dev-libs/nettle
+ net-dns/libidn2
+ dev-libs/libunistring"
+RDEPEND="${DEPEND}"
+
+# For working tests we need a fix for opendkim,
+# see https://bugs.gentoo.org/700174
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ diropts -o mail -g mail
+ dodir /etc/courier/filters/keys
+ dodoc release-notes-*.txt README ChangeLog
+ dodoc odbx_example.{conf,sql}
+}