summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-22 18:39:38 +0100
committerSam James <sam@gentoo.org>2022-04-22 18:43:05 +0100
commit1d46cd30c3f4982cd2a52e6ddd347ca53fea7875 (patch)
tree1d4145896479c412bc9de731fc0415b8fefba9fb /mail-mta/courier
parentdev-lang/perl: fix ROOT check in pkg_postinst (diff)
downloadgentoo-1d46cd30c3f4982cd2a52e6ddd347ca53fea7875.tar.gz
gentoo-1d46cd30c3f4982cd2a52e6ddd347ca53fea7875.tar.bz2
gentoo-1d46cd30c3f4982cd2a52e6ddd347ca53fea7875.zip
mail-mta/courier: fix ROOT check in pkg_postinst
With EAPI 7+, ROOT and others will be blank (not /). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-mta/courier')
-rw-r--r--mail-mta/courier/courier-1.1.5-r3.ebuild (renamed from mail-mta/courier/courier-1.1.5-r2.ebuild)2
-rw-r--r--mail-mta/courier/courier-1.1.8-r2.ebuild (renamed from mail-mta/courier/courier-1.1.8-r1.ebuild)2
2 files changed, 2 insertions, 2 deletions
diff --git a/mail-mta/courier/courier-1.1.5-r2.ebuild b/mail-mta/courier/courier-1.1.5-r3.ebuild
index 3ef7bf19c50c..6011e0efbe2e 100644
--- a/mail-mta/courier/courier-1.1.5-r2.ebuild
+++ b/mail-mta/courier/courier-1.1.5-r3.ebuild
@@ -264,7 +264,7 @@ pkg_config() {
fi
export domainname
- if [ "${ROOT}" = "/" ] ; then
+ if [[ -z "${ROOT}" ]] ; then
file="${ROOT}/etc/courier/locals"
if [ ! -f "${file}" ] ; then
echo "localhost" > "${file}";
diff --git a/mail-mta/courier/courier-1.1.8-r1.ebuild b/mail-mta/courier/courier-1.1.8-r2.ebuild
index 55023ee74943..6862c3007f92 100644
--- a/mail-mta/courier/courier-1.1.8-r1.ebuild
+++ b/mail-mta/courier/courier-1.1.8-r2.ebuild
@@ -265,7 +265,7 @@ pkg_config() {
fi
export domainname
- if [ "${ROOT}" = "/" ] ; then
+ if [[ -z "${ROOT}" ]] ; then
file="${ROOT}/etc/courier/locals"
if [ ! -f "${file}" ] ; then
echo "localhost" > "${file}";