summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-03-02 17:37:51 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-03-02 17:38:16 +0100
commit8146a1f86e72210919cd8a0020aaf19838da0637 (patch)
tree087156ac5a8865891ca33488e95a2de821b9f3e6 /mail-mta/opensmtpd/opensmtpd-5.7.3_p2-r1.ebuild
parentsys-apps/systemd: Describe subslots (diff)
downloadgentoo-8146a1f86e72210919cd8a0020aaf19838da0637.tar.gz
gentoo-8146a1f86e72210919cd8a0020aaf19838da0637.tar.bz2
gentoo-8146a1f86e72210919cd8a0020aaf19838da0637.zip
mail-mta/opensmtpd: do not crash with libressl
Diffstat (limited to 'mail-mta/opensmtpd/opensmtpd-5.7.3_p2-r1.ebuild')
-rw-r--r--mail-mta/opensmtpd/opensmtpd-5.7.3_p2-r1.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/mail-mta/opensmtpd/opensmtpd-5.7.3_p2-r1.ebuild b/mail-mta/opensmtpd/opensmtpd-5.7.3_p2-r1.ebuild
deleted file mode 100644
index ef9a28680ae7..000000000000
--- a/mail-mta/opensmtpd/opensmtpd-5.7.3_p2-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools systemd versionator
-
-DESCRIPTION="Lightweight but featured SMTP daemon from OpenBSD"
-HOMEPAGE="http://www.opensmtpd.org/"
-MY_P="${P}"
-if [ $(get_last_version_component_index) -eq 4 ]; then
- MY_P="${PN}-$(get_version_component_range 4-)"
-fi
-SRC_URI="https://www.opensmtpd.org/archives/${MY_P/_}.tar.gz"
-
-LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="libressl pam +mta"
-
-DEPEND="!libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- sys-libs/zlib
- pam? ( virtual/pam )
- sys-libs/db:=
- dev-libs/libevent
- app-misc/ca-certificates
- net-mail/mailbase
- net-libs/libasr
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp[mta]
- !mail-mta/netqmail
- !mail-mta/nullmailer
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/ssmtp[mta]
-"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P/_}
-
-src_prepare() {
- # Use /run instead of /var/run
- sed -i -e '/pidfile_path/s:_PATH_VARRUN:"/run/":' openbsd-compat/pidfile.c || die
-
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- tc-export AR
- AR="$(which "$AR")" econf \
- --enable-table-db \
- --with-privsep-user=smtpd \
- --with-queue-user=smtpq \
- --with-privsep-path=/var/empty \
- --with-sock-dir=/run \
- --sysconfdir=/etc/opensmtpd \
- --with-ca-file=/etc/ssl/certs/ca-certificates.crt \
- $(use_with pam)
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}"/smtpd.initd smtpd
- systemd_dounit "${FILESDIR}"/smtpd.{service,socket}
- use pam && newpamd "${FILESDIR}"/smtpd.pam smtpd
- if use mta ; then
- dodir /usr/sbin
- dosym /usr/sbin/smtpctl /usr/sbin/sendmail
- dosym /usr/sbin/smtpctl /usr/bin/sendmail
- dosym /usr/sbin/smtpctl /usr/$(get_libdir)/sendmail
- fi
-}
-
-pkg_preinst() {
- enewgroup smtpd 25
- enewuser smtpd 25 -1 /var/empty smtpd
- enewgroup smtpq 252
- enewuser smtpq 252 -1 /var/empty smtpq
-}
-
-pkg_postinst() {
- einfo
- einfo "Plugins for SQLite, MySQL, PostgreSQL, LDAP, socketmaps,"
- einfo "Redis, and many other useful addons and filters are"
- einfo "available in the mail-filter/opensmtpd-extras package."
- einfo
-}