summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-01 05:35:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-01 05:43:55 -0400
commit2bc8fa7f3b24750c97641e3e3301d9d7f4bd4df7 (patch)
tree2d0b105fa39e38695cf4fdb4ee213302816dd060 /mail-mta
parentmail-mta/sendmail: add libnsl dep for USE=nis and update other deps (diff)
downloadgentoo-2bc8fa7f3b24750c97641e3e3301d9d7f4bd4df7.tar.gz
gentoo-2bc8fa7f3b24750c97641e3e3301d9d7f4bd4df7.tar.bz2
gentoo-2bc8fa7f3b24750c97641e3e3301d9d7f4bd4df7.zip
mail-mta/sendmail: tidy, use pkg-config, extra error checking
|| die was missing in several places (notably all here-documents), and direct "make" was likely used because emake needs -j1 like libmilter. Use pkg-config where possible, single-string -> sed -> m4 layout should ideally be replaced to handle potential use of spaces or other characters that this or *FLAGS may generate. Simplified most constructs for easier maintenance, sorted, and removed the unused multilib inherit. Avoided changes that may alter build or configuration files. Also added a note to bump together with libmilter. Closes: https://bugs.gentoo.org/681232 Closes: https://github.com/gentoo/gentoo/pull/21069 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/sendmail/sendmail-8.16.1-r1.ebuild178
1 files changed, 88 insertions, 90 deletions
diff --git a/mail-mta/sendmail/sendmail-8.16.1-r1.ebuild b/mail-mta/sendmail/sendmail-8.16.1-r1.ebuild
index 8de7878ecb71..8b5b4f3cdc07 100644
--- a/mail-mta/sendmail/sendmail-8.16.1-r1.ebuild
+++ b/mail-mta/sendmail/sendmail-8.16.1-r1.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit multilib systemd toolchain-funcs
+# Note: please bump this together with mail-filter/libmilter
+
+inherit systemd toolchain-funcs
DESCRIPTION="Widely-used Mail Transport Agent (MTA)"
HOMEPAGE="https://www.sendmail.org/"
@@ -11,20 +13,23 @@ SRC_URI="ftp://ftp.sendmail.org/pub/${PN}/${PN}.${PV}.tar.gz"
LICENSE="Sendmail GPL-2" # GPL-2 is here for initscript
SLOT="0"
+# TODO: restore keywords soon for bug 730890 after testing
#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="ipv6 ldap mbox nis sasl sockets ssl tcpd"
-BDEPEND="sys-devel/m4"
-DEPEND="net-mail/mailbase
+BDEPEND="
+ sys-devel/m4
+ virtual/pkgconfig"
+DEPEND="
+ net-mail/mailbase
+ >=sys-libs/db-3.2:=
+ ldap? ( net-nds/openldap )
nis? ( net-libs/libnsl:= )
sasl? ( >=dev-libs/cyrus-sasl-2.1.10 )
- tcpd? ( sys-apps/tcp-wrappers )
- ssl? (
- dev-libs/openssl:0=
- )
- ldap? ( net-nds/openldap )
- >=sys-libs/db-3.2:="
-RDEPEND="${DEPEND}
+ ssl? ( dev-libs/openssl:0= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="
+ ${DEPEND}
acct-group/smmsp
>=acct-user/smmsp-0-r2
>=mail-filter/libmilter-1.0.2_p1-r1
@@ -35,62 +40,65 @@ RDEPEND="${DEPEND}
!mail-mta/msmtp[mta]
!mail-mta/netqmail
!mail-mta/nullmailer
- !mail-mta/postfix
!mail-mta/opensmtpd
+ !mail-mta/postfix
!mail-mta/qmail-ldap
!>=mail-mta/ssmtp-2.64-r2[mta]
!net-mail/vacation"
-
PDEPEND="!mbox? ( mail-filter/procmail )"
src_prepare() {
- eapply "${FILESDIR}"/"${PN}"-8.16.1-build-system.patch
- eapply -p0 "${FILESDIR}"/sendmail-delivered_hdr.patch
+ eapply "${FILESDIR}"/${PN}-8.16.1-build-system.patch
+ eapply -p0 "${FILESDIR}"/${PN}-delivered_hdr.patch
+ eapply_user
- local confCC="$(tc-getCC)"
local confCCOPTS="${CFLAGS}"
+ local confENVDEF="-DMAXDAEMONS=64 -DHAS_GETHOSTBYNAME2=1"
local confLDOPTS="${LDFLAGS}"
+ local confLIBS=
local confMAPDEF="-DMAP_REGEX"
- local confENVDEF="-DMAXDAEMONS=64"
- local conf_sendmail_LIBS=""
-
- confENVDEF="${confLIBS} -DHAS_GETHOSTBYNAME2=1"
-
- use sasl && confLIBS="${confLIBS} -lsasl2" \
- && confENVDEF="${confENVDEF} -DSASL=2" \
- && confCCOPTS="${confCCOPTS} -I/usr/include/sasl" \
- && conf_sendmail_LIBS="${conf_sendmail_LIBS} -lsasl2"
-
- use tcpd && confENVDEF="${confENVDEF} -DTCPWRAPPERS" \
- && confLIBS="${confLIBS} -lwrap"
-
- # Bug #542370 - lets add support for modern crypto (PFS)
- use ssl && confENVDEF="${confENVDEF} -DSTARTTLS -D_FFR_DEAL_WITH_ERROR_SSL" \
- && confENVDEF="${confENVDEF} -D_FFR_TLS_1 -D_FFR_TLS_EC" \
- && confLIBS="${confLIBS} -lssl -lcrypto" \
- && conf_sendmail_LIBS="${conf_sendmail_LIBS} -lssl -lcrypto"
-
- use ldap && confMAPDEF="${confMAPDEF} -DLDAPMAP" \
- && confLIBS="${confLIBS} -lldap -llber"
+ local conf_sendmail_LIBS=
- use ipv6 && confENVDEF="${confENVDEF} -DNETINET6"
-
- use nis && confENVDEF="${confENVDEF} -DNIS"
+ if use ldap; then
+ confMAPDEF+=" -DLDAPMAP"
+ confLIBS+=" -lldap -llber"
+ fi
- use sockets && confENVDEF="${confENVDEF} -DSOCKETMAP"
+ if use sasl; then
+ confCCOPTS+=" $($(tc-getPKG_CONFIG) --cflags libsasl2)"
+ confENVDEF+=" -DSASL=2"
+ conf_sendmail_LIBS+=" $($(tc-getPKG_CONFIG) --libs libsasl2)"
+ fi
- sed -e "s:@@confCCOPTS@@:${confCCOPTS}:" \
- -e "s/@@confLDOPTS@@/${confLDOPTS}/" \
- -e "s/@@confCC@@/${confCC}/" \
- -e "s/@@confMAPDEF@@/${confMAPDEF}/" \
- -e "s/@@confENVDEF@@/${confENVDEF}/" \
- -e "s/@@confLIBS@@/${confLIBS}/" \
- -e "s/@@conf_sendmail_LIBS@@/${conf_sendmail_LIBS}/" \
- "${FILESDIR}"/site.config.m4 > devtools/Site/site.config.m4 || die "sed failed"
+ if use ssl; then
+ # Bug #542370 - lets add support for modern crypto (PFS)
+ confCCOPTS+=" $($(tc-getPKG_CONFIG) --cflags openssl)"
+ confENVDEF+=" -DSTARTTLS -D_FFR_DEAL_WITH_ERROR_SSL"
+ confENVDEF+=" -D_FFR_TLS_1 -D_FFR_TLS_EC"
+ conf_sendmail_LIBS+=" $($(tc-getPKG_CONFIG) --libs openssl)"
+ fi
- echo "APPENDDEF(\`confLIBDIRS', \`-L${EPREFIX}/usr/$(get_libdir)')" >> devtools/Site/site.config.m4 || die "echo failed"
+ if use tcpd; then
+ confENVDEF+=" -DTCPWRAPPERS"
+ confLIBS+=" -lwrap"
+ fi
- eapply_user
+ use ipv6 && confENVDEF+=" -DNETINET6"
+ use nis && confENVDEF+=" -DNIS"
+ use sockets && confENVDEF+=" -DSOCKETMAP"
+
+ sed -e "s|@@confCC@@|$(tc-getCC)|" \
+ -e "s|@@confCCOPTS@@|${confCCOPTS}|" \
+ -e "s|@@confENVDEF@@|${confENVDEF}|" \
+ -e "s|@@confLDOPTS@@|${confLDOPTS}|" \
+ -e "s|@@confLIBS@@|${confLIBS}|" \
+ -e "s|@@confMAPDEF@@|${confMAPDEF}|" \
+ -e "s|@@conf_sendmail_LIBS@@|${conf_sendmail_LIBS}|" \
+ "${FILESDIR}"/site.config.m4 > devtools/Site/site.config.m4 \
+ || die "failed to generate site.config.m4"
+
+ echo "APPENDDEF(\`confLIBDIRS', \`-L${EPREFIX}/usr/$(get_libdir)')" \
+ >> devtools/Site/site.config.m4 || die "failed adding to site.config.m4"
}
src_compile() {
@@ -98,35 +106,27 @@ src_compile() {
}
src_install() {
- local MY_LIBDIR=/usr/$(get_libdir)
- local MY_OBJDIR="obj.`uname -s`.`uname -r`.`uname -m`"
-
- dodir /usr/bin ${MY_LIBDIR}
+ dodir /usr/{bin,$(get_libdir)}
dodir /usr/share/man/man{1,5,8} /usr/sbin /usr/share/sendmail-cf
dodir /var/spool/{mqueue,clientmqueue} /etc/conf.d
keepdir /var/spool/{clientmqueue,mqueue}
- for dir in libsmutil sendmail mailstats praliases smrsh makemap vacation editmap
- do
- make DESTDIR="${D}" LIBDIR="${MY_LIBDIR}" MANROOT=/usr/share/man/man \
- SBINOWN=root SBINGRP=root UBINOWN=root UBINGRP=root \
- MANOWN=root MANGRP=root INCOWN=root INCGRP=root \
- LIBOWN=root LIBGRP=root GBINOWN=root GBINGRP=root \
- MSPQOWN=root CFOWN=root CFGRP=root \
- install -C "${MY_OBJDIR}/${dir}" \
- || die "install 1 failed"
- done
+ local emakeargs=(
+ DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)"
+ MANROOT=/usr/share/man/man
+ SBINOWN=root SBINGRP=root UBINOWN=root UBINGRP=root
+ MANOWN=root MANGRP=root INCOWN=root INCGRP=root
+ LIBOWN=root LIBGRP=root GBINOWN=root GBINGRP=root
+ MSPQOWN=root CFOWN=root CFGRP=root
+ )
- for dir in rmail mail.local
- do
- make DESTDIR="${D}" LIBDIR="${MY_LIBDIR}" MANROOT=/usr/share/man/man \
- SBINOWN=root SBINGRP=root UBINOWN=root UBINGRP=root \
- MANOWN=root MANGRP=root INCOWN=root INCGRP=root \
- LIBOWN=root LIBGRP=root GBINOWN=root GBINGRP=root \
- MSPQOWN=root CFOWN=root CFGRP=root \
- force-install -C "${MY_OBJDIR}/${dir}" \
- || die "install 2 failed"
+ local dir
+ for dir in libsmutil sendmail mailstats praliases smrsh makemap vacation editmap; do
+ emake -j1 -C obj.*/${dir} "${emakeargs[@]}" install
+ done
+ for dir in rmail mail.local; do
+ emake -j1 -C obj.*/${dir} "${emakeargs[@]}" force-install
done
fowners root:smmsp /usr/sbin/sendmail
@@ -137,21 +137,18 @@ src_install() {
dosym ../sbin/makemap /usr/bin/makemap
dodoc FAQ KNOWNBUGS README RELEASE_NOTES doc/op/op.ps
+ dodoc sendmail/{SECURITY,TUNING}
newdoc sendmail/README README.sendmail
- newdoc sendmail/SECURITY SECURITY
- newdoc sendmail/TUNING TUNING
newdoc smrsh/README README.smrsh
newdoc cf/README README.cf
newdoc cf/cf/README README.install-cf
- cp -pPR cf/* "${ED}"/usr/share/sendmail-cf || die "copy failed"
+ dodoc -r contrib
- docinto contrib
- dodoc contrib/*
+ cp -pPR cf/. "${ED}"/usr/share/sendmail-cf || die
insinto /etc/mail
-
if use mbox; then
newins "${FILESDIR}"/sendmail.mc-r1 sendmail.mc
else
@@ -160,23 +157,24 @@ src_install() {
# See discussion on bug #730890
m4 "${ED}"/usr/share/sendmail-cf/m4/cf.m4 \
- <(grep -v "${EPREFIX}"/usr/share/sendmail-cf/m4/cf.m4 "${ED}"/etc/mail/sendmail.mc) \
- > "${ED}"/etc/mail/sendmail.cf || die "cf.m4 failed"
+ <(grep -v "${EPREFIX}"/usr/share/sendmail-cf/m4/cf.m4 "${ED}"/etc/mail/sendmail.mc) \
+ > "${ED}"/etc/mail/sendmail.cf || die "cf.m4 failed"
echo "include(\`/usr/share/sendmail-cf/m4/cf.m4')dnl" \
- > "${ED}"/etc/mail/submit.mc || die "echo failed"
+ > "${ED}"/etc/mail/submit.mc || die "submit.mc echo failed"
- cat "${ED}"/usr/share/sendmail-cf/cf/submit.mc >> "${ED}"/etc/mail/submit.mc || die "submit.mc cat failed"
+ cat "${ED}"/usr/share/sendmail-cf/cf/submit.mc \
+ >> "${ED}"/etc/mail/submit.mc || die "submit.mc cat failed"
echo "# local-host-names - include all aliases for your machine here" \
- > "${D}"/etc/mail/local-host-names || die "local-host-names echo failed"
+ > "${ED}"/etc/mail/local-host-names || die "local-host-names echo failed"
- cat <<- EOF > "${ED}"/etc/mail/trusted-users
+ cat <<- EOF > "${ED}"/etc/mail/trusted-users || die "trusted-users cat failed"
# trusted-users - users that can send mail as others without a warning
# apache, mailman, majordomo, uucp are good candidates
EOF
- cat <<- EOF > "${ED}"/etc/mail/access
+ cat <<- EOF > "${ED}"/etc/mail/access || die "access cat failed"
# Check the /usr/share/doc/sendmail/README.cf file for a description
# of the format of this file. (search for access_db in that file)
# The /usr/share/doc/sendmail/README.cf is part of the sendmail-doc
@@ -185,7 +183,7 @@ src_install() {
EOF
- cat <<- EOF > "${ED}"/etc/conf.d/sendmail
+ cat <<- EOF > "${ED}"/etc/conf.d/sendmail || die "sendmail cat failed"
# Config file for /etc/init.d/sendmail
# add start-up options here
SENDMAIL_OPTS="-bd -q30m -L sm-mta" # default daemon mode
@@ -196,9 +194,9 @@ src_install() {
if use sasl; then
dodir /etc/sasl2
- cat <<- EOF > "${ED}"/etc/sasl2/Sendmail.conf
- pwcheck_method: saslauthd
- mech_list: PLAIN LOGIN
+ cat <<- EOF > "${ED}"/etc/sasl2/Sendmail.conf || die "Sendmail.conf cat ailed"
+ pwcheck_method: saslauthd
+ mech_list: PLAIN LOGIN
EOF
fi