summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mate-base/mate-menus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mate-base/mate-menus')
-rw-r--r--mate-base/mate-menus/Manifest1
-rw-r--r--mate-base/mate-menus/files/10-xdg-menu-mate6
-rw-r--r--mate-base/mate-menus/mate-menus-1.8.0.ebuild82
-rw-r--r--mate-base/mate-menus/metadata.xml8
4 files changed, 97 insertions, 0 deletions
diff --git a/mate-base/mate-menus/Manifest b/mate-base/mate-menus/Manifest
new file mode 100644
index 000000000000..67097f395704
--- /dev/null
+++ b/mate-base/mate-menus/Manifest
@@ -0,0 +1 @@
+DIST mate-menus-1.8.0.tar.xz 342768 SHA256 0610c1c5c2348e8bcd1dae7bed808c451917a69b31d4b80de2b2f6288005b43c SHA512 724c0f4d98cabcc8d186e27024f116ba97ed4219ea563aecf14c22ef8d6b4dc1f5281ace2f836a5cfa32984e43cb3dd2b0ac1a9390dde9d477394c74a62348a0 WHIRLPOOL e5671a62f60eb8560a62e9f5e12267cd8cae34817a51a31afc58e26d3787ec7e9bdd2e17e81a3119892f2dc03df11004455d4c75247bef224428041003f3439b
diff --git a/mate-base/mate-menus/files/10-xdg-menu-mate b/mate-base/mate-menus/files/10-xdg-menu-mate
new file mode 100644
index 000000000000..06a6a91368e2
--- /dev/null
+++ b/mate-base/mate-menus/files/10-xdg-menu-mate
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+if [ -z "$XDG_MENU_PREFIX" ] && [ "$DESKTOP_SESSION" = "mate" ]
+then
+ export XDG_MENU_PREFIX=mate-
+fi
diff --git a/mate-base/mate-menus/mate-menus-1.8.0.ebuild b/mate-base/mate-menus/mate-menus-1.8.0.ebuild
new file mode 100644
index 000000000000..58d81766b8b1
--- /dev/null
+++ b/mate-base/mate-menus/mate-menus-1.8.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-r1
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="debug +introspection python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/glib-2.15.2:2
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:0 )
+ python? (
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40:*
+ >=mate-base/mate-common-1.8:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+my_command() {
+ if use python ; then
+ python_foreach_impl run_in_build_dir $@
+ else
+ $@
+ fi
+}
+
+src_configure() {
+ G2CONF="${G2CONF} \
+ $(use_enable python) \
+ $(use_enable introspection)"
+
+ # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
+ # usage checks.
+ if ! use debug ; then
+ G2CONF="${G2CONF} --enable-debug=minimum"
+ fi
+
+ if use python ; then
+ python_copy_sources
+ fi
+
+ my_command gnome2_src_configure
+}
+
+src_compile() {
+ my_command gnome2_src_compile
+}
+
+src_test() {
+ my_command emake check
+}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_install() {
+ my_command gnome2_src_install
+
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/10-xdg-menu-mate"
+}
diff --git a/mate-base/mate-menus/metadata.xml b/mate-base/mate-menus/metadata.xml
new file mode 100644
index 000000000000..e356fdf21ce7
--- /dev/null
+++ b/mate-base/mate-menus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <upstream>
+ <remote-id type="github">mate-desktop/mate-menus</remote-id>
+ </upstream>
+</pkgmetadata>