summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGokturk Yuksek <gokturk@binghamton.edu>2015-01-03 16:13:00 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-01-24 04:22:17 -0500
commitb4d9f2580ecc35ed4f3b07eca904ec078bc9fcff (patch)
tree2226c36936e76ca59c6909c7949e5d9e26239c70 /mate-base
parentapp-emulation/wine: Update metadata.xml with gstreamer description (diff)
downloadgentoo-b4d9f2580ecc35ed4f3b07eca904ec078bc9fcff.tar.gz
gentoo-b4d9f2580ecc35ed4f3b07eca904ec078bc9fcff.tar.bz2
gentoo-b4d9f2580ecc35ed4f3b07eca904ec078bc9fcff.zip
mate-base/mate-panel: fix compilation failure with networkmanager #570266
mate-panel-1.8.1 fails to compile with >=net-misc/networkmanager-1.0.8 due to a missing include directive ('-I'). Substitute network manager CFLAGS and LIBS supplied by the pkgconfig macro in configure.ac and use it for applets/clock. Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=570266 Upstream-PR-URL: https://github.com/mate-desktop/mate-panel/pull/388 Package-Manager: portage-2.2.24 Signed-off-by: NP-Hardass <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-panel/files/mate-panel-1.8.1-fix-networkmanager-flags.patch53
-rw-r--r--mate-base/mate-panel/mate-panel-1.8.1-r1.ebuild5
2 files changed, 56 insertions, 2 deletions
diff --git a/mate-base/mate-panel/files/mate-panel-1.8.1-fix-networkmanager-flags.patch b/mate-base/mate-panel/files/mate-panel-1.8.1-fix-networkmanager-flags.patch
new file mode 100644
index 000000000000..f67726919792
--- /dev/null
+++ b/mate-base/mate-panel/files/mate-panel-1.8.1-fix-networkmanager-flags.patch
@@ -0,0 +1,53 @@
+From f03dff4c416d417238dcd625a24ea85e380e599c Mon Sep 17 00:00:00 2001
+From: Gokturk Yuksek <gokturk@binghamton.edu>
+Date: Sun, 3 Jan 2016 03:17:40 -0500
+Subject: [PATCH 1/1] applets/clock: add missing pkgconfig flags for
+ NetworkManager
+
+mate-panel-1.8 fails to compile with NetworkManager >=1.0.8 due to a
+missing include directive ('-I'). Substitute network manager CFLAGS
+and LIBS supplied by the pkgconfig macro in configure.ac and use it
+for applets/clock.
+
+Signed-off-by: Gokturk Yuksek <gokturk@binghamton.edu>
+---
+ applets/clock/Makefile.am | 2 ++
+ configure.ac | 2 ++
+ 2 files changed, 4 insertions(+)
+
+diff --git a/applets/clock/Makefile.am b/applets/clock/Makefile.am
+index 950ecdd..bfb6b45 100644
+--- a/applets/clock/Makefile.am
++++ b/applets/clock/Makefile.am
+@@ -39,6 +39,7 @@ CLOCK_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(LIBMATE_PANEL_APPLET_CFLAGS) \
+ $(CLOCK_CFLAGS) \
++ $(NETWORK_MANAGER_CFLAGS) \
+ -I$(srcdir)/../../libmate-panel-applet \
+ -I$(top_builddir)/libmate-panel-applet \
+ -DMATELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+@@ -51,6 +52,7 @@ CLOCK_LDADD = \
+ ../../libmate-panel-applet/libmate-panel-applet-4.la \
+ $(CLOCK_LIBS) \
+ $(LIBMATE_PANEL_APPLET_LIBS) \
++ $(NETWORK_MANAGER_LIBS) \
+ libsystem-timezone.la \
+ -lm
+
+diff --git a/configure.ac b/configure.ac
+index af5a422..6d1389e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -156,6 +156,8 @@ else
+ fi
+ if test "x$HAVE_NETWORK_MANAGER" = "xyes" ; then
+ AC_DEFINE(HAVE_NETWORK_MANAGER, 1, [Defined if NetworkManager support is enabled])
++ AC_SUBST(NETWORK_MANAGER_CFLAGS)
++ AC_SUBST(NETWORK_MANAGER_LIBS)
+ fi
+
+ # Make it possible to compile the applets in-process
+--
+2.4.10
+
diff --git a/mate-base/mate-panel/mate-panel-1.8.1-r1.ebuild b/mate-base/mate-panel/mate-panel-1.8.1-r1.ebuild
index 6bef4413a702..5acf34de129e 100644
--- a/mate-base/mate-panel/mate-panel-1.8.1-r1.ebuild
+++ b/mate-base/mate-panel/mate-panel-1.8.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -60,7 +60,8 @@ src_prepare() {
# Disable python check.
sed -e '/AM_PATH_PYTHON/d' -i configure.ac || die
- epatch "${FILESDIR}/${P}-update_marco_wm_name.patch"
+ epatch "${FILESDIR}/${P}-update_marco_wm_name.patch" \
+ "${FILESDIR}/${P}-fix-networkmanager-flags.patch"
epatch_user