summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-09-04 12:13:00 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-09-25 16:32:06 -0400
commite712ec8d337ebb9cd38c86e99586b3b8dc9b2e72 (patch)
treeb6f757f35a096cf0050f37cfda7831137528487c /mate-base
parentmate-base/mate-menus: Bump to 1.24.1 (diff)
downloadgentoo-e712ec8d337ebb9cd38c86e99586b3b8dc9b2e72.tar.gz
gentoo-e712ec8d337ebb9cd38c86e99586b3b8dc9b2e72.tar.bz2
gentoo-e712ec8d337ebb9cd38c86e99586b3b8dc9b2e72.zip
mate-base/mate-panel: Bump to 1.24.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-panel/Manifest1
-rw-r--r--mate-base/mate-panel/mate-panel-1.24.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index 779ef5733fb2..23a659327471 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1 +1,2 @@
DIST mate-panel-1.24.0.tar.xz 3040068 BLAKE2B 2ef2973014e32ab62ba9d4a05a820a2640415b493886d74e09089ed91bfe61d2d53ee6313c104945ddc95c992423403f6bca72a7f8b80ce189cd9f247add931c SHA512 12a88534400603998b4d4d415940947dd6372914135aa8eb6052c75e134412739a96064ad654e8f2625dbb6fe853e8cb376c41e530c30234e08141a46634820b
+DIST mate-panel-1.24.1.tar.xz 3265000 BLAKE2B eb5d2c8b6668ecb1d072e80ac4062574c97b7d52a1473133efff0fb12eca4e765df016d8ede4c6745f7bd9e6ea64114ccfcdf87045ca00797e63ab9ec215435c SHA512 1a1e62207d58472daa00d409ef2b04944929af7f9fe05592076adcc069e2d70012424b3386d30f8b9adccf05c328b8ab1662b8726e507465881a4ae26c26829f
diff --git a/mate-base/mate-panel/mate-panel-1.24.1.ebuild b/mate-base/mate-panel/mate-panel-1.24.1.ebuild
new file mode 100644
index 000000000000..6b5b93b187ea
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.24.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="X +introspection wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/librsvg-2.36.2:2
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.21.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1.0.0[X?]
+ >=x11-libs/gdk-pixbuf-2.25.2:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ X? (
+ x11-libs/libX11
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}