summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-09-14 11:43:18 -0400
committerEttore Di Giacinto <mudler@gentoo.org>2016-11-21 12:00:49 +0100
commitdbe6362846102be480e7a5b5ba6ca458e56b89b4 (patch)
tree3cb814df2be7cca9425219f534e6d690f8bebd8d /mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1-r1.ebuild
parentmate-base/mate-control-center: apply appindicator patch to 1.14.1, #593678 (diff)
downloadgentoo-dbe6362846102be480e7a5b5ba6ca458e56b89b4.tar.gz
gentoo-dbe6362846102be480e7a5b5ba6ca458e56b89b4.tar.bz2
gentoo-dbe6362846102be480e7a5b5ba6ca458e56b89b4.zip
mate-extra/mate-indicator-applet: Fix configure.ac for indicator-ng #593680
Package-Manager: portage-2.3.0
Diffstat (limited to 'mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1-r1.ebuild')
-rw-r--r--mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1-r1.ebuild b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1-r1.ebuild
new file mode 100644
index 000000000000..605c790c1d8e
--- /dev/null
+++ b/mate-extra/mate-indicator-applet/mate-indicator-applet-1.14.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit mate versionator
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="MATE indicator applet"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="gtk3"
+
+COMMON_DEPEND="
+ >=mate-base/mate-panel-1.8[gtk3(-)=]
+ !gtk3? (
+ >=dev-libs/libindicator-0.3.90:0
+ >=x11-libs/gtk+-2.24:2
+ )
+ gtk3? (
+ >=dev-libs/libindicator-0.3.90:3
+ >=x11-libs/gtk+-3.0:3
+ )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-indicator-ng-configure-fix.patch" )
+
+src_configure() {
+ mate_src_configure \
+ --with-gtk=$(usex gtk3 3.0 2.0)
+}