summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-09-04 17:26:43 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-09-25 16:32:17 -0400
commit104085c26974134eebba253eb84d1aee582dc61a (patch)
tree249ac6f8caa3eab892cbb5643bea34ea2a6a722c /mate-extra/mate-system-monitor
parentmate-extra/mate-power-manager: Bump to 1.24.2 (diff)
downloadgentoo-104085c26974134eebba253eb84d1aee582dc61a.tar.gz
gentoo-104085c26974134eebba253eb84d1aee582dc61a.tar.bz2
gentoo-104085c26974134eebba253eb84d1aee582dc61a.zip
mate-extra/mate-system-monitor: Bump to 1.24.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-extra/mate-system-monitor')
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index d286c453bd2a..c9dc4a0e0fc8 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1 +1,2 @@
DIST mate-system-monitor-1.24.0.tar.xz 2437396 BLAKE2B 78c8774ee1832772b2cda06bca051c91e10e882b841373e3f30575ab1d05cc2b799962d964be4cc8416f9747e44031e579410d9851bb82d6a13f6023f1a30b2a SHA512 430a2bf81f447143ba53cecb1c2659903cd957e313f6690adea363e9a8deccfd4ad64ebd8ce18dfb31a67fa7b51cbe087ffed7b5dcba5dd03b1010ec41b4d282
+DIST mate-system-monitor-1.24.1.tar.xz 2420872 BLAKE2B 27572e523ea358a5315b6a42dc29e6c48c4341d4cdf34edb039429a455e1d924417aeb8602e0a71d4e71b04988ccadc82bc84794411644eefb1bd976e5744e90 SHA512 5fdf8ff52584f91fbe12270af2b5bb1c81d5c4d6001bdaad9c6001dbb6e6020254048e32aa6549eb686ad17998c1aa220e5463057502ba514c4a5b82953f2b05
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild
new file mode 100644
index 000000000000..a489ee3adc34
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind systemd"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.56:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.0:3
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=()
+
+ if use elogind || use systemd; then
+ myconf+=( --enable-systemd )
+ if use elogind; then
+ myconf+=(
+ SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
+ SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ )
+ fi
+ else
+ myconf+=( --disable-systemd )
+ fi
+
+ mate_src_configure "${myconf[@]}"
+}