summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-03-17 02:11:14 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-03-17 14:11:09 +0300
commit1fb94eb56eac0c66796dcb3ac66b5a3c671eefb4 (patch)
treefe5d24ea0a8028ecc7fdb1b709756eca835df7d1 /mate-extra/mate-system-monitor
parentmate-extra/mate-user-guide: Version bump (v1.22.0) (diff)
downloadgentoo-1fb94eb56eac0c66796dcb3ac66b5a3c671eefb4.tar.gz
gentoo-1fb94eb56eac0c66796dcb3ac66b5a3c671eefb4.tar.bz2
gentoo-1fb94eb56eac0c66796dcb3ac66b5a3c671eefb4.zip
mate-extra/mate-system-monitor: Version bump (v1.22.0)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'mate-extra/mate-system-monitor')
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.22.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index 9ff69d91563a..9f7e57a766db 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1 +1,2 @@
DIST mate-system-monitor-1.18.1.tar.xz 2159100 BLAKE2B babac7ad0dc3a3bccf5c6d4567bee0c95aad1f5fffdb1d6d566316f4712a345e7083c8032c19b6615a9f9d06fbbe8b89357407b897206f3131294b7d2305b45d SHA512 47dd2ba46cd6fbd1beef2e6f0a93332c7142f701d18f6894b4986134c557f63f3e2bed382af17cc5bf45693b556a91ccab36fde940126fdceb5834d4cea08356
+DIST mate-system-monitor-1.22.0.tar.xz 2190688 BLAKE2B 83ab7dfbc0033f094896c663790c1200e71a498d3a813a82c94593e6c6434942b2afd0fa1c3067452a46e0e1829a9239f1c145a315b9de2c2853c9f4f50618ef SHA512 6f97f934626b49320ea0dbb4e14743c4f33b12a85671b69465f689765f3003f00e51685b616e34a482c3ec0ca09ca4e13cbdb2e3eb4719c0d1fc7b25b24436a7
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.22.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.22.0.ebuild
new file mode 100644
index 000000000000..e9a646ba5d13
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.22.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="systemd"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.50:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.23.1:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.0:3
+ virtual/libintl
+ systemd? ( sys-apps/systemd )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable systemd)
+}
+