summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-12-12 22:04:35 -0500
committerMike Gilbert <floppym@gentoo.org>2020-12-14 11:45:18 -0500
commit59f1666ed50efdc20fb89ed20f6b3bc12f592c76 (patch)
tree897a69a700b4b876a1d2d4c1abfb694acb547d11 /mate-extra/mate-system-monitor
parentgnome-base/gdm: fix quoting for pkg-config (diff)
downloadgentoo-59f1666ed50efdc20fb89ed20f6b3bc12f592c76.tar.gz
gentoo-59f1666ed50efdc20fb89ed20f6b3bc12f592c76.tar.bz2
gentoo-59f1666ed50efdc20fb89ed20f6b3bc12f592c76.zip
mate-extra/mate-system-monitor: fix quoting for pkg-config
Bug: https://bugs.gentoo.org/756238 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'mate-extra/mate-system-monitor')
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild7
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
index d6a7c0848c40..5634e8c0117e 100644
--- a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit mate
+inherit mate toolchain-funcs
if [[ ${PV} != 9999 ]]; then
KEYWORDS="amd64 ~arm ~arm64 x86"
@@ -51,9 +51,10 @@ src_configure() {
if use elogind || use systemd; then
myconf+=( --enable-systemd )
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
- SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi
else
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild
index a489ee3adc34..a031a4ddd4c4 100644
--- a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit mate
+inherit mate toolchain-funcs
if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
@@ -51,9 +51,10 @@ src_configure() {
if use elogind || use systemd; then
myconf+=( --enable-systemd )
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
- SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi
else