summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 20:44:19 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2016-02-08 21:46:56 -0500
commit37394c815ee4dd25d19948da1b9a537683726fbb (patch)
tree744e80d84950b5eef781d4f53183bd2c36587c62 /mate-extra
parentmate-extra/mate-user-share: Import 1.10.x from Project:MATE repo (diff)
downloadgentoo-37394c815ee4dd25d19948da1b9a537683726fbb.tar.gz
gentoo-37394c815ee4dd25d19948da1b9a537683726fbb.tar.bz2
gentoo-37394c815ee4dd25d19948da1b9a537683726fbb.zip
mate-extra/mate-utils: Import 1.10.x from Project:MATE repo
Package-Manager: portage-2.2.26
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-utils/Manifest1
-rw-r--r--mate-extra/mate-utils/mate-utils-1.10.4.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/mate-extra/mate-utils/Manifest b/mate-extra/mate-utils/Manifest
index 2e3f0c00991e..4097052ab4f7 100644
--- a/mate-extra/mate-utils/Manifest
+++ b/mate-extra/mate-utils/Manifest
@@ -1,2 +1,3 @@
+DIST mate-utils-1.10.4.tar.xz 6482724 SHA256 a15610f42c5b4f4f2cd6aef876080912297edde5ba568dfd42f066afc876d491 SHA512 7d162f21efec756abb4429e7e4ed461286ea0fda9e7279610eb8e9fe4b5af1782759f28b98574042e3c9e5cdfd2d00e0f59a16ea56a1852af47f35a8c7e99f79 WHIRLPOOL 3689a7c4921c53369c5a8b009de276a50b7420799528ec55bdba03493a9b4f6ebf4d21216a31bdffc2968fbfb83355c2f077d694c75e60fca1ad3af7a2989b13
DIST mate-utils-1.8.0.tar.xz 2681836 SHA256 490d187d67c4f542cf3b8e63337acc1a9b7090c519adb844600b9d00da0b5cf0 SHA512 766fce72f7b486c3aa67e9a40b10207fbca36e7933cb7238bf0d6ac5a5e5165d5900ceb697c9af96f1135110b9b3985e349e9bc071a5174fe3fe0776ba0c4cd5 WHIRLPOOL 77fff5f47c83fa6884403f30194b606346659651f077912364907d8e3b6ad95e9eae974012aa8c54db31381231190077d362e402afe4f87279695871ab78144b
DIST mate-utils-1.8.1.tar.xz 2648184 SHA256 0ad9c40c656214caaa6cbd2107ebb13e3cea0b64b4e31c7105568726313522a5 SHA512 71a6a57365a067012447222b2ef4b768234b2e58bf88b5b45c6e4b7f746c81136ea1dfee45257406b19f2c4f4c51adc3279b09f7c9c41bfe7be9c66321ad0eef WHIRLPOOL fc35c564fb378ebfc147b9344790aae5a3934e86f6cf642dedb2ab98ae093bb259e298f4fa6de98157f3c4775445862888a56464de8852d829e6040f9a42fc95
diff --git a/mate-extra/mate-utils/mate-utils-1.10.4.ebuild b/mate-extra/mate-utils/mate-utils-1.10.4.ebuild
new file mode 100644
index 000000000000..b43ae622640f
--- /dev/null
+++ b/mate-extra/mate-utils/mate-utils-1.10.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Utilities for the MATE desktop"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="X applet ipv6 test"
+
+RDEPEND="app-text/rarian:0
+ dev-libs/atk:0
+ >=dev-libs/glib-2.36:2
+ >=gnome-base/libgtop-2.12:2=
+ >=media-libs/libcanberra-0.4:0[gtk]
+ sys-libs/zlib:0
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/cairo:0
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ x11-libs/libX11:0
+ x11-libs/libXext:0
+ x11-libs/pango:0
+ applet? ( >=mate-base/mate-panel-1.10:0 )"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.50:*
+ >=mate-base/mate-common-1.10:0
+ x11-proto/xextproto:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove -D.*DISABLE_DEPRECATED cflagss
+ # This method is kinda prone to breakage. Recheck carefully with next bump.
+ # bug 339074
+ LC_ALL=C find . -iname 'Makefile.am' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die
+
+ # Do Makefile.in after Makefile.am to avoid automake maintainer-mode
+ LC_ALL=C find . -iname 'Makefile.in' -exec \
+ sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die
+
+ if ! use test; then
+ sed -e 's/ tests//' -i logview/Makefile.{am,in} || die
+ fi
+
+ # Fix up desktop files.
+ LC_ALL=C find . -iname '*.desktop.in*' -exec \
+ sed -e 's/Categories\(.*\)MATE/Categories\1X-MATE/' -i {} + || die
+}
+
+src_configure() {
+ local myconf
+ if ! use debug; then
+ myconf="${myconf} --enable-debug=minimum"
+ fi
+
+ gnome2_src_configure \
+ $(use_enable applet gdict-applet) \
+ $(use_enable ipv6) \
+ $(use_with X x) \
+ --disable-maintainer-flags \
+ --enable-zlib \
+ ${myconf}
+}
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"