summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/baekmuk-fonts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/baekmuk-fonts')
-rw-r--r--media-fonts/baekmuk-fonts/Manifest3
-rw-r--r--media-fonts/baekmuk-fonts/baekmuk-fonts-2.2-r2.ebuild45
-rw-r--r--media-fonts/baekmuk-fonts/metadata.xml6
3 files changed, 54 insertions, 0 deletions
diff --git a/media-fonts/baekmuk-fonts/Manifest b/media-fonts/baekmuk-fonts/Manifest
new file mode 100644
index 000000000000..bb5e6ee197a9
--- /dev/null
+++ b/media-fonts/baekmuk-fonts/Manifest
@@ -0,0 +1,3 @@
+DIST 20020418.tar.bz2 1841477 SHA256 c2dc189d5ce6610cdf78d568d902146fa9e4a89ac13d404fbe1bc26ec66e9bba
+DIST baekmuk-bdf-2.2.tar.gz 9547995 SHA256 eec120d5c7e41672c2157fb4e1040a532f1d4de79e4845c28b243d73a4daa54c
+DIST baekmuk-ttf-2.2.tar.gz 29241850 SHA256 08ab7dffb55d5887cc942ce370f5e33b756a55fbb4eaf0b90f244070e8d51882
diff --git a/media-fonts/baekmuk-fonts/baekmuk-fonts-2.2-r2.ebuild b/media-fonts/baekmuk-fonts/baekmuk-fonts-2.2-r2.ebuild
new file mode 100644
index 000000000000..219260114531
--- /dev/null
+++ b/media-fonts/baekmuk-fonts/baekmuk-fonts-2.2-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit font font-ebdftopcf
+
+TTF_P="${P/fonts/ttf}"
+BDF_P="${P/fonts/bdf}"
+UNI_P="20020418"
+
+DESCRIPTION="Korean Baekmuk Font"
+HOMEPAGE="http://kldp.net/projects/baekmuk/"
+SRC_URI="http://kldp.net/download.php/1429/${TTF_P}.tar.gz
+ http://kldp.net/download.php/1428/${BDF_P}.tar.gz
+ unicode? ( http://chem.skku.ac.kr/~wkpark/baekmuk/iso10646/${UNI_P}.tar.bz2 )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="unicode"
+
+S=${WORKDIR}
+
+# Only installs fonts
+RESTRICT="strip binchecks"
+
+src_unpack() {
+ unpack ${BDF_P}.tar.gz ${TTF_P}.tar.gz
+
+ if use unicode ; then
+ cd "${WORKDIR}/${BDF_P}/bdf"
+ unpack ${UNI_P}.tar.bz2
+ fi
+}
+
+src_compile() {
+ cd ${BDF_P}/bdf
+ font-ebdftopcf_src_compile
+}
+
+src_install () {
+ FONT_S="${S}/${TTF_P}/ttf" FONT_SUFFIX="ttf" font_src_install
+ use X && FONT_S="${S}/${BDF_P}/bdf" FONT_SUFFIX="pcf.gz" font_src_install
+ use X || FONT_S="${S}/${BDF_P}/bdf" FONT_SUFFIX="bdf" font_src_install
+}
diff --git a/media-fonts/baekmuk-fonts/metadata.xml b/media-fonts/baekmuk-fonts/metadata.xml
new file mode 100644
index 000000000000..6e63c30f1bb2
--- /dev/null
+++ b/media-fonts/baekmuk-fonts/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>fonts</herd>
+<herd>cjk</herd>
+</pkgmetadata>