summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-14 08:46:37 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-14 08:47:29 +0200
commite78211aee93c35f99704065f8cbdc18651fb3438 (patch)
treef525f72e55dc6e0759c5b5425acd3dbda699c274 /media-fonts/fira-code/fira-code-2.ebuild
parentprofiles: arm64: Promote media-video/pipewire to p.use.stable.mask (diff)
downloadgentoo-e78211aee93c35f99704065f8cbdc18651fb3438.tar.gz
gentoo-e78211aee93c35f99704065f8cbdc18651fb3438.tar.bz2
gentoo-e78211aee93c35f99704065f8cbdc18651fb3438.zip
media-fonts/fira-code: add 2
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'media-fonts/fira-code/fira-code-2.ebuild')
-rw-r--r--media-fonts/fira-code/fira-code-2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-fonts/fira-code/fira-code-2.ebuild b/media-fonts/fira-code/fira-code-2.ebuild
new file mode 100644
index 000000000000..7f97b424cbfe
--- /dev/null
+++ b/media-fonts/fira-code/fira-code-2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit font
+
+DESCRIPTION="Monospaced font with programming ligatures"
+HOMEPAGE="https://github.com/tonsky/FiraCode"
+SRC_URI="https://github.com/tonsky/FiraCode/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/tonsky/FiraCode/files/412440/FiraCode-Regular-Symbol.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/FiraCode-${PV}"
+FONT_S="${S}/distr/otf"
+FONT_SUFFIX="otf"
+
+DOCS="README.md"
+
+src_prepare() {
+ default
+ mv "${WORKDIR}"/*.otf "${FONT_S}" || die
+}