summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-19 06:13:50 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-19 11:36:48 +0200
commit453b0a75737e9ff31d71e7768a7fcba7fba8c8ec (patch)
tree37187f9c292aeb1ec38f8764c674d0646e0d37e8 /media-fonts/fira-code/fira-code-4.ebuild
parentwww-servers/tomcat: bump to 7.0.104 (diff)
downloadgentoo-453b0a75737e9ff31d71e7768a7fcba7fba8c8ec.tar.gz
gentoo-453b0a75737e9ff31d71e7768a7fcba7fba8c8ec.tar.bz2
gentoo-453b0a75737e9ff31d71e7768a7fcba7fba8c8ec.zip
media-fonts/fira-code: add 4
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'media-fonts/fira-code/fira-code-4.ebuild')
-rw-r--r--media-fonts/fira-code/fira-code-4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-fonts/fira-code/fira-code-4.ebuild b/media-fonts/fira-code/fira-code-4.ebuild
new file mode 100644
index 000000000000..73fe57c4a3dc
--- /dev/null
+++ b/media-fonts/fira-code/fira-code-4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit font
+
+DESCRIPTION="Monospaced font with programming ligatures"
+HOMEPAGE="https://github.com/tonsky/FiraCode"
+SRC_URI="https://github.com/tonsky/FiraCode/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/tonsky/FiraCode/files/412440/FiraCode-Regular-Symbol.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/FiraCode-${PV}"
+FONT_S="${S}/distr/ttf"
+FONT_SUFFIX="ttf otf"
+
+DOCS="README.md"
+
+DEPEND="app-arch/unzip"
+
+src_prepare() {
+ default
+ mv "${WORKDIR}"/*.otf "${FONT_S}" || die
+}