summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/mathematica-fonts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/mathematica-fonts')
-rw-r--r--media-fonts/mathematica-fonts/Manifest2
-rw-r--r--media-fonts/mathematica-fonts/mathematica-fonts-10.0.ebuild22
-rw-r--r--media-fonts/mathematica-fonts/mathematica-fonts-7.0.ebuild40
-rw-r--r--media-fonts/mathematica-fonts/metadata.xml5
4 files changed, 69 insertions, 0 deletions
diff --git a/media-fonts/mathematica-fonts/Manifest b/media-fonts/mathematica-fonts/Manifest
new file mode 100644
index 000000000000..fd5b2fc88a2f
--- /dev/null
+++ b/media-fonts/mathematica-fonts/Manifest
@@ -0,0 +1,2 @@
+DIST MathematicaV7FontsLinux.tar.gz 8597655 SHA256 69b4ca6f7c864df6ff517c6636823881de6283392321708a9b2b515f1f292eb4
+DIST mathematica-fonts-10.0.zip 586368 SHA256 e15299b5a12ab7b149d7f28c5dec984999dd519e47ab503035d9a7d067e73002 SHA512 4429163c427bc762cdaf7d310985becff97f78e7b452b184e9cb64f5f787559d283b5438a16f4e6bfaeffe86429bd416d2772707350830f646c70f53b519f4c7 WHIRLPOOL ffe260a6b8ce9654ac876afc9aba1ed9f7a459b15edd6824b9619f3812be852464748022f391a0150f19eabcfe0c8c1523a9fce113cbac4da115de3a9f0f7b2e
diff --git a/media-fonts/mathematica-fonts/mathematica-fonts-10.0.ebuild b/media-fonts/mathematica-fonts/mathematica-fonts-10.0.ebuild
new file mode 100644
index 000000000000..70d2dd7c3b73
--- /dev/null
+++ b/media-fonts/mathematica-fonts/mathematica-fonts-10.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit font
+
+DESCRIPTION="Mathematica's Fonts for MathML"
+HOMEPAGE="http://www.wolfram.com/mathematica"
+SRC_URI="http://support.wolfram.com/kb/data/uploads/2014/08/TrueType.zip -> ${P}.zip"
+
+LICENSE="WRI-EULA"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT="binchecks mirror strip"
+
+S="${WORKDIR}"
+FONT_S="${S}"/TrueType
+FONT_SUFFIX="ttf"
diff --git a/media-fonts/mathematica-fonts/mathematica-fonts-7.0.ebuild b/media-fonts/mathematica-fonts/mathematica-fonts-7.0.ebuild
new file mode 100644
index 000000000000..e27e20018e9e
--- /dev/null
+++ b/media-fonts/mathematica-fonts/mathematica-fonts-7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit font
+
+DESCRIPTION="Mathematica's Fonts for MathML"
+HOMEPAGE="http://support.wolfram.com/technotes/latestfonts.en.html"
+SRC_URI="http://support.wolfram.com/technotes/MathematicaV7FontsLinux.tar.gz"
+
+LICENSE="WRI-EULA"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT="mirror strip binchecks"
+S=${WORKDIR}
+
+src_install() {
+ FONT_S="${S}"/Fonts/TTF FONT_SUFFIX="ttf" font_src_install
+ FONT_S="${S}"/Fonts/Type1 FONT_SUFFIX="pfa" font_src_install
+}
+
+pkg_postinst() {
+ einfo
+ ewarn "Previously we suggested to set fonts in Mozilla or Firefox browsers."
+ ewarn "If you did that, please, revert back since now everything should work"
+ ewarn "out of box and no manual configuration required."
+ einfo
+ elog "To reset open web browser, enter the URL 'about:config', 'Filter' for"
+ elog "'mathfont', and 'Reset' to the default value through the context menu on"
+ elog "the preference."
+ elog
+ elog "Although if you still wish to use this fonts for MathML in web brower, then"
+ elog "set font.mathfont-family to:"
+ elog "Mathematica1, Mathematica2, Mathematica3, Mathematica4, Mathematica5, Mathematica6, Mathematica7"
+ elog
+ elog "Test your fonts at http://www.mozilla.org/projects/mathml/start.xhtml"
+ einfo
+}
diff --git a/media-fonts/mathematica-fonts/metadata.xml b/media-fonts/mathematica-fonts/metadata.xml
new file mode 100644
index 000000000000..696065edd338
--- /dev/null
+++ b/media-fonts/mathematica-fonts/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>fonts</herd>
+</pkgmetadata>