summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-09-20 23:50:21 +0200
committerSebastian Pipping <sping@gentoo.org>2018-09-21 00:10:43 +0200
commite92658356c92d1bee109ebce19d60e7ab51269e5 (patch)
tree137884443e60c4191243d839dc71db08ad4af22f /media-fonts/mplus-fonts/mplus-fonts-2.2.4-r1.ebuild
parentmedia-fonts/encodings: Turn into well-behaved font (diff)
downloadgentoo-e92658356c92d1bee109ebce19d60e7ab51269e5.tar.gz
gentoo-e92658356c92d1bee109ebce19d60e7ab51269e5.tar.bz2
gentoo-e92658356c92d1bee109ebce19d60e7ab51269e5.zip
media-fonts/mplus-fonts: Turn into well-behaved font + EAPI 6
Lack of file /usr/share/fonts/mplus/.uuid causes sandbox violation issues in other packages. font_pkg_postinst take care of its creation now. Bug: https://bugs.gentoo.org/665008 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-fonts/mplus-fonts/mplus-fonts-2.2.4-r1.ebuild')
-rw-r--r--media-fonts/mplus-fonts/mplus-fonts-2.2.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-fonts/mplus-fonts/mplus-fonts-2.2.4-r1.ebuild b/media-fonts/mplus-fonts/mplus-fonts-2.2.4-r1.ebuild
new file mode 100644
index 000000000000..d26999296ce6
--- /dev/null
+++ b/media-fonts/mplus-fonts/mplus-fonts-2.2.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+FONT_PN=mplus
+
+inherit font
+
+MY_P="mplus_bitmap_fonts-${PV}"
+
+DESCRIPTION="M+ Japanese bitmap fonts"
+HOMEPAGE="http://mplus-fonts.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/5030/${MY_P}.tar.gz"
+
+LICENSE="mplus-fonts"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X"
+
+DEPEND="x11-apps/mkfontdir
+ x11-apps/bdftopcf"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+# Only installs fonts
+RESTRICT="strip binchecks"
+
+src_install(){
+ DESTDIR="${D}${FONTDIR}" ./install_mplus_fonts || die
+ dodoc README* INSTALL*
+}