summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-21 14:44:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-21 20:05:51 +0100
commitd943987b86a14df2beaf2e06cb40eeae093ee667 (patch)
tree52b19dbfa3e1c4652a8afde26829a7dcc9391f5a /media-fonts/mplus-outline-fonts
parentmedia-fonts/mplus-fonts: EAPI-7 bump, update HOMEPAGE (diff)
downloadgentoo-d943987b86a14df2beaf2e06cb40eeae093ee667.tar.gz
gentoo-d943987b86a14df2beaf2e06cb40eeae093ee667.tar.bz2
gentoo-d943987b86a14df2beaf2e06cb40eeae093ee667.zip
media-fonts/mplus-outline-fonts: EAPI-7 bump, fix HOMEPAGE
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-fonts/mplus-outline-fonts')
-rw-r--r--media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre063_p1.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre063_p1.ebuild b/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre063_p1.ebuild
index 2ddd4e3cbe3b..314af0dd5627 100644
--- a/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre063_p1.ebuild
+++ b/media-fonts/mplus-outline-fonts/mplus-outline-fonts-0_pre063_p1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit font
@@ -9,8 +9,9 @@ MY_P="mplus-${PV/0_pre/TESTFLIGHT-}"
MY_P="${MY_P/_p1/a}"
DESCRIPTION="M+ Japanese outline fonts"
-HOMEPAGE="http://mplus-fonts.osdn.jp/ http://ossipedia.ipa.go.jp/ipafont/"
+HOMEPAGE="https://mplus-fonts.osdn.jp/about-en.html"
SRC_URI="mirror://sourceforge.jp/mplus-fonts/62344/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
LICENSE="mplus-fonts ipafont? ( IPAfont )"
SLOT="0"
@@ -18,22 +19,21 @@ KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~x86 ~ppc-macos"
IUSE="ipafont"
RESTRICT="binchecks strip"
-DEPEND="ipafont? (
- media-gfx/fontforge
+BDEPEND="
+ ipafont? (
media-fonts/ja-ipafonts
+ media-gfx/fontforge
)"
-RDEPEND=""
-S="${WORKDIR}/${MY_P}"
+
+DOCS=( README_J README_E )
FONT_SUFFIX="ttf"
-FONT_S="${S}"
-DOCS="README_J README_E"
IPAFONT_DIR="${EPREFIX}/usr/share/fonts/ja-ipafonts"
src_prepare() {
if use ipafont; then
- cp -p "${IPAFONT_DIR}"/ipag.ttf "${S}" || die
+ cp -p "${IPAFONT_DIR}"/ipag.ttf . || die
fi
default
}
@@ -41,6 +41,6 @@ src_prepare() {
src_compile() {
if use ipafont; then
fontforge -script m++ipa.pe || die
- rm -f ipag.ttf
+ rm -f ipag.ttf || die
fi
}