summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/source-han-sans/source-han-sans-1.001.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/source-han-sans/source-han-sans-1.001.ebuild')
-rw-r--r--media-fonts/source-han-sans/source-han-sans-1.001.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-fonts/source-han-sans/source-han-sans-1.001.ebuild b/media-fonts/source-han-sans/source-han-sans-1.001.ebuild
new file mode 100644
index 000000000000..0cb9b6054212
--- /dev/null
+++ b/media-fonts/source-han-sans/source-han-sans-1.001.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit font
+
+# Note to maintainers:
+# The upstream tarball is huge (over 780 MB), so we repackage the
+# regional subset OTF fonts per region, for the user's convenience.
+
+DESCRIPTION="Pan-CJK OpenType/CFF font family"
+HOMEPAGE="https://github.com/adobe-fonts/source-han-sans/"
+SRC_URI="linguas_ja? ( http://dev.gentoo.org/~yngwin/distfiles/${PN}-ja-${PV}.tar.xz )
+ linguas_ko? ( http://dev.gentoo.org/~yngwin/distfiles/${PN}-ko-${PV}.tar.xz )
+ linguas_zh_CN? ( http://dev.gentoo.org/~yngwin/distfiles/${PN}-zh_CN-${PV}.tar.xz )
+ linguas_zh_TW? ( http://dev.gentoo.org/~yngwin/distfiles/${PN}-zh_TW-${PV}.tar.xz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~x64-macos"
+IUSE="linguas_ja linguas_ko +linguas_zh_CN linguas_zh_TW"
+REQUIRED_USE="|| ( linguas_ja linguas_ko linguas_zh_CN linguas_zh_TW )"
+
+S=${WORKDIR}
+FONT_SUFFIX="otf"
+RESTRICT="binchecks strip"
+
+src_install() {
+ for l in ja ko zh_CN zh_TW; do
+ use linguas_${l} && FONT_S="${S}/source-han-sans-${l}-${PV}" font_src_install
+ done
+ dodoc source-han-sans-*-${PV}/*md source-han-sans-*-${PV}/*pdf
+}