summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-fonts/urwvn-fonts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-fonts/urwvn-fonts')
-rw-r--r--media-fonts/urwvn-fonts/Manifest1
-rw-r--r--media-fonts/urwvn-fonts/files/65-urwvn.conf18
-rw-r--r--media-fonts/urwvn-fonts/metadata.xml8
-rw-r--r--media-fonts/urwvn-fonts/urwvn-fonts-3.05.ebuild32
4 files changed, 59 insertions, 0 deletions
diff --git a/media-fonts/urwvn-fonts/Manifest b/media-fonts/urwvn-fonts/Manifest
new file mode 100644
index 000000000000..fa1e6321e47e
--- /dev/null
+++ b/media-fonts/urwvn-fonts/Manifest
@@ -0,0 +1 @@
+DIST urwvn-3.05-ttf.tar.bz2 1322045 SHA256 0a46ae92129eb5857d61c9e82af2811fd6492efe382a1389024f7de9527f0981
diff --git a/media-fonts/urwvn-fonts/files/65-urwvn.conf b/media-fonts/urwvn-fonts/files/65-urwvn.conf
new file mode 100644
index 000000000000..d68f368fccdb
--- /dev/null
+++ b/media-fonts/urwvn-fonts/files/65-urwvn.conf
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
+<!-- /etc/fonts/conf.d/57-dejavu-sans.conf
+
+ Define aliasing and other fontconfig settings for
+ DejaVu Sans.
+
+ © 2006-2008 Nicolas Mailhot <nicolas.mailhot at laposte.net>
+-->
+<fontconfig>
+ <!-- Font substitution rules -->
+ <alias binding="same">
+ <family>Vn Utopia</family>
+ <accept>
+ <family>Vntopia</family>
+ </accept>
+ </alias>
+</fontconfig>
diff --git a/media-fonts/urwvn-fonts/metadata.xml b/media-fonts/urwvn-fonts/metadata.xml
new file mode 100644
index 000000000000..0fe59e2fba00
--- /dev/null
+++ b/media-fonts/urwvn-fonts/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>fonts</herd>
+ <upstream>
+ <remote-id type="sourceforge">vntex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-fonts/urwvn-fonts/urwvn-fonts-3.05.ebuild b/media-fonts/urwvn-fonts/urwvn-fonts-3.05.ebuild
new file mode 100644
index 000000000000..d943852ca80f
--- /dev/null
+++ b/media-fonts/urwvn-fonts/urwvn-fonts-3.05.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit font
+
+MY_P=${P/_/-}
+MY_P=${MY_P/-fonts/}
+DESCRIPTION="fonts gpl'd by Han The Thanh, based on URW++ fonts with Vietnamese glyphs added"
+# Check updates on:
+# http://vntex.sf.net/fonts/urwvn-ttf/download
+# https://sourceforge.net/projects/vntex/files
+HOMEPAGE="http://vntex.sf.net"
+SRC_URI="mirror://sourceforge/project/vntex/urwvn-ttf/${MY_P}-ttf.tar.bz2"
+
+LICENSE="GPL-2 Aladdin" # see bug #434262
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}-ttf"
+FONT_SUFFIX="ttf"
+FONT_S=${S}
+FONT_CONF=( "${FILESDIR}/65-urwvn.conf" )
+
+pkg_postinst() {
+ font_pkg_postinst
+ ewarn 'For legal reasons "Vn Utopia" font was renamed to "Vntopia".'
+ ewarn 'If you configured some programs to use "Vn Utopia", please,'
+ ewarn 'enable aliases (65-urwvn.conf) with `eselect fontconfig`.'
+}