summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-08-07 13:47:46 -0700
committerMatt Turner <mattst88@gentoo.org>2020-08-07 15:52:10 -0700
commit06a296c86966e393c796190cdf287e2bdad59494 (patch)
treec64c5f5f6dce27ce22e47f8448064c0395e324d8 /media-fonts
parentmedia-fonts/font-alias: Version bump to 1.0.4 (diff)
downloadgentoo-06a296c86966e393c796190cdf287e2bdad59494.tar.gz
gentoo-06a296c86966e393c796190cdf287e2bdad59494.tar.bz2
gentoo-06a296c86966e393c796190cdf287e2bdad59494.zip
media-fonts/font-misc-ethiopic: Version bump to 1.0.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/font-misc-ethiopic/Manifest1
-rw-r--r--media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.4.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/media-fonts/font-misc-ethiopic/Manifest b/media-fonts/font-misc-ethiopic/Manifest
index 5389338f4b99..d75850858a93 100644
--- a/media-fonts/font-misc-ethiopic/Manifest
+++ b/media-fonts/font-misc-ethiopic/Manifest
@@ -1 +1,2 @@
DIST font-misc-ethiopic-1.0.3.tar.bz2 245606 BLAKE2B e0cf89f4500226b7213d6f3f88b3bf575501140d8742fe5e30b07eefd2c1fe2fc9bfe941639032d3b5ce45eb7e6f352af7b6468e7f8b0fc941ed9cee8d531f96 SHA512 b3e3f7462f37216796730a894761c7d60d5ede0f51351997e6c3c92e3136c788a2710690f482d05ed1396a4b6be452e1f871febc7e5b7a1a67e43bcc1ec7c77d
+DIST font-misc-ethiopic-1.0.4.tar.bz2 270076 BLAKE2B b27d188fcb5be3e4e5fed810f26c0f5edf5a51a3532bd51b44e55283518bc1a353054da4f37c5535197eeb6958bfe1567ab54d1d9f428b046b84c5d1233aae21 SHA512 4fed9ff3782746898c56dac199e9ca89356f4967779937049b9ff4ffad202317c023859f92d44b371dfa5485d5368ccad648e64b12cde0ed21f7d4aee5affcd5
diff --git a/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.4.ebuild b/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.4.ebuild
new file mode 100644
index 000000000000..cc322ce05390
--- /dev/null
+++ b/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+FONT_DIR="OTF"
+
+inherit xorg-3
+
+DESCRIPTION="Miscellaneous Ethiopic fonts"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-fontrootdir="${EPREFIX}/usr/share/fonts"
+
+ # This flag unexpectedly doesn't control whether the font (i.e. the .ttf file)
+ # is installed, but instead only controls whether mkfontscale/mkfontdir is
+ # run. I suspect this is a bug.
+ --disable-truetype-install
+)
+
+src_install() {
+ xorg-3_src_install
+
+ # TTF fonts are not supposed to be installed.
+ rm -r "${ED}/usr/share/fonts/TTF" || die
+}