summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/album
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/album')
-rw-r--r--media-gfx/album/Manifest3
-rw-r--r--media-gfx/album/album-4.07.ebuild40
-rw-r--r--media-gfx/album/album-4.13.ebuild40
-rw-r--r--media-gfx/album/metadata.xml9
4 files changed, 92 insertions, 0 deletions
diff --git a/media-gfx/album/Manifest b/media-gfx/album/Manifest
new file mode 100644
index 000000000000..29289348eda2
--- /dev/null
+++ b/media-gfx/album/Manifest
@@ -0,0 +1,3 @@
+DIST album-4.07.tar.gz 619238 SHA256 eed9a3abe206397afaf21f445178845aa38159f359dc0dffd3174dd8b26ae0e8 SHA512 dde914a8a0f0dd5896d069ad22c47db645f1acefc9c2d1a7047862185e3b96b0c4fb2c9681d8838eaf3de40b49082b9c06d848340aa92ecb8f398d9fd31273ba WHIRLPOOL 2fbcf5ce69a45b8b1005e2aa4642be17066eea74f5a9573ac074106595eedf1d69bc72135ae1939e80400c98afd4347964662d6380cf629046317dfd6bc1b4e0
+DIST album-4.13.tar.gz 667760 SHA256 b25c4d27546b710175f1a482f5222371fa6deefa011d31c68035f46b94f19b06 SHA512 c22bbc5ad154f35d50d28e5331911d0fd32c5e7f25b659e48274baa1ccc9e3e8b9f771a1bfdf39078c9e959c3fd84b3ccd8528f20f7a80baa7c59bc579579756 WHIRLPOOL 56ba2457a5e583e0228b563e0d1d9443a1ef0a1b83a7444ed31368814b3e21bc017d421a8f080a639f72dfb563ec062f132dc082d9dafd137a773c5883f2396f
+DIST data-4.05.tar.gz 6468036 SHA256 e1ee211d652f886494b84e957cd9a2f34b8a6b1fb3adad320484a62ce30debc6 SHA512 a7c577df6d10dc2db53fa6d469d2cf9c5115de99df47e79f31ecc0b009bd12e654e4ca7b9e6e78abe90a8a87d5f52ca9946a2d632e3f219d9bcb5ab7838ce42e WHIRLPOOL 00831d65b611652301310b743276cdd5434a9702c8a92a220267aa8ccf28783aaef7e9de57f8493f446e261c14eb7020ea4edd1a2dfdf4942d17f88c051b6800
diff --git a/media-gfx/album/album-4.07.ebuild b/media-gfx/album/album-4.07.ebuild
new file mode 100644
index 000000000000..9e47e43e94cd
--- /dev/null
+++ b/media-gfx/album/album-4.07.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="HTML photo album generator"
+HOMEPAGE="http://MarginalHacks.com/Hacks/album/"
+SRC_URI="http://marginalhacks.com/bin/album.versions/${P}.tar.gz
+ http://marginalhacks.com/bin/album.versions/data-4.05.tar.gz"
+
+LICENSE="marginalhacks"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="doc ffmpeg plugins themes"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ media-gfx/imagemagick
+ media-gfx/jhead
+ ffmpeg? ( virtual/ffmpeg )"
+
+src_install() {
+ dobin album
+ doman album.1
+ dodoc License.txt CHANGELOG
+ use doc && dohtml -r Docs/*
+
+ dodir /usr/share/album
+ insinto /usr/share/album
+ cd ..
+ doins -r lang
+ use themes && doins -r Themes
+ use plugins && doins -r plugins
+}
+
+pkg_postinst() {
+ elog "For some optional tools please browse:"
+ elog "http://MarginalHacks.com/Hacks/album/tools/"
+}
diff --git a/media-gfx/album/album-4.13.ebuild b/media-gfx/album/album-4.13.ebuild
new file mode 100644
index 000000000000..8ef0a2a5e15d
--- /dev/null
+++ b/media-gfx/album/album-4.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="HTML photo album generator"
+HOMEPAGE="http://MarginalHacks.com/Hacks/album/"
+SRC_URI="http://marginalhacks.com/bin/album.versions/${P}.tar.gz
+ http://marginalhacks.com/bin/album.versions/data-4.05.tar.gz"
+
+LICENSE="marginalhacks"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc ffmpeg plugins themes"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ media-gfx/jhead
+ ffmpeg? ( virtual/ffmpeg )"
+
+src_install() {
+ dobin album
+ doman album.1
+ dodoc License.txt CHANGELOG
+ use doc && dohtml -r Docs/*
+
+ dodir /usr/share/album
+ insinto /usr/share/album
+ cd ..
+ doins -r lang
+ use themes && doins -r Themes
+ use plugins && doins -r plugins
+}
+
+pkg_postinst() {
+ elog "For some optional tools please browse:"
+ elog "http://MarginalHacks.com/Hacks/album/tools/"
+}
diff --git a/media-gfx/album/metadata.xml b/media-gfx/album/metadata.xml
new file mode 100644
index 000000000000..f99fc2d51a77
--- /dev/null
+++ b/media-gfx/album/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+<use>
+ <flag name="plugins">Install optional plugins</flag>
+ <flag name="themes">Install optional themes</flag>
+</use>
+</pkgmetadata>