summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/aqsis/aqsis-1.8.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/aqsis/aqsis-1.8.2.ebuild')
-rw-r--r--media-gfx/aqsis/aqsis-1.8.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-gfx/aqsis/aqsis-1.8.2.ebuild b/media-gfx/aqsis/aqsis-1.8.2.ebuild
new file mode 100644
index 000000000000..02ae317704e9
--- /dev/null
+++ b/media-gfx/aqsis/aqsis-1.8.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="Open source RenderMan-compliant 3D rendering solution"
+HOMEPAGE="http://www.aqsis.org"
+SRC_URI="mirror://sourceforge/aqsis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="png qt4"
+
+# OpenEXR currently can not be optional dependency, despite build system options
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/tinyxml
+ media-libs/tiff:0
+ sys-libs/zlib
+ media-libs/openexr:=
+ png? ( media-libs/libpng:0= )
+ qt4? ( dev-qt/qtgui:4 )
+"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ sys-devel/bison
+ sys-devel/flex
+"
+
+DOCS=( AUTHORS INSTALL README )
+PATCHES=(
+ "${FILESDIR}/${P}-openexr-compat.patch"
+ "${FILESDIR}/${P}-unbundle-tinyxml.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use png AQSIS_USE_PNG)
+ $(cmake-utils_use qt4 AQSIS_USE_QT)
+ -DAQSIS_ENABLE_DOCS=OFF
+ -DAQSIS_USE_EXTERNAL_TINYXML=ON
+ -DAQSIS_USE_OPENEXR=ON
+ -DAQSIS_USE_RPATH=OFF
+ -DLIBDIR="$(get_libdir)"
+ -DSYSCONFDIR="/etc"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newdoc "release-notes/1.8/summary-1.8.0.txt" ReleaseNotes
+ cmake-utils_src_install
+}