summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:06:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:26:12 +0100
commit4e716ed8da37c97742a65cc17d8446640f37b4dc (patch)
tree6ce52363a9858cce86ad2dec50ed7a0dc7599a15 /media-gfx/autopano-sift-C
parentgames-strategy/freesynd: Drop 0.7.1-r1 (diff)
downloadgentoo-4e716ed8da37c97742a65cc17d8446640f37b4dc.tar.gz
gentoo-4e716ed8da37c97742a65cc17d8446640f37b4dc.tar.bz2
gentoo-4e716ed8da37c97742a65cc17d8446640f37b4dc.zip
media-gfx/autopano-sift-C: Switch to cmake.eclass, fix build
Thanks-to: Mr.Chauv <mr.chauv@mailbox.org> Closes: https://bugs.gentoo.org/759514 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/autopano-sift-C')
-rw-r--r--media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild11
-rw-r--r--media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-include-order.patch24
2 files changed, 31 insertions, 4 deletions
diff --git a/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild b/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
index b9fffc443b2a..aa6387758510 100644
--- a/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
+++ b/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="SIFT algorithm for automatic panorama creation in C"
HOMEPAGE="http://hugin.sourceforge.net/ http://user.cs.tu-berlin.de/~nowozin/autopano-sift/"
@@ -25,4 +25,7 @@ RDEPEND="${DEPEND}
!media-gfx/autopano-sift
"
-PATCHES=( "${FILESDIR}"/${P}-lm.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-lm.patch
+ "${FILESDIR}"/${P}-include-order.patch # bug 759514
+)
diff --git a/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-include-order.patch b/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-include-order.patch
new file mode 100644
index 000000000000..becab6d4aeb1
--- /dev/null
+++ b/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-include-order.patch
@@ -0,0 +1,24 @@
+Subject: [PATCH] adjust to include order deoendency
+
+---
+ autopano-sift-C-2.5.1/KeypointXML.c | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/autopano-sift-C-2.5.1/KeypointXML.c b/autopano-sift-C-2.5.1/KeypointXML.c
+index 9da70a8..30c35e1 100644
+--- a/KeypointXML.c
++++ b/KeypointXML.c
+@@ -13,10 +13,9 @@
+ * (C) Copyright 2004 -- Sebastian Nowozin (nowozin@cs.tu-berlin.de)
+ */
+
+-#include "AutoPanoSift.h"
+-
+ #include <libxml/xmlreader.h>
+ #include <libxml/xmlwriter.h>
++#include "AutoPanoSift.h"
+
+ KeypointXMLList* KeypointXMLReader_ReadComplete (char* filename)
+ {
+--
+2.26.2