summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/autopano-sift-C
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/autopano-sift-C')
-rw-r--r--media-gfx/autopano-sift-C/Manifest1
-rw-r--r--media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild31
-rw-r--r--media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-lm.patch14
-rw-r--r--media-gfx/autopano-sift-C/metadata.xml10
4 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/autopano-sift-C/Manifest b/media-gfx/autopano-sift-C/Manifest
new file mode 100644
index 000000000000..71e4d5c8e9f0
--- /dev/null
+++ b/media-gfx/autopano-sift-C/Manifest
@@ -0,0 +1 @@
+DIST autopano-sift-C-2.5.1.tar.gz 192267 SHA256 9a9029353f240b105a9c0e31e4053b37b0f9ef4bd9166dcb26be3e819c431337 SHA512 4f3c9e8738c7bc29ff6284033b7b813de61ef440c3d544755be8c4ad715a6e4175801ee4c02642df5e05bac82929c5554d85a5c488a2c27da1e5e81d3cd72931 WHIRLPOOL 95f54d93cf5162b1b88dccb6750ed5b59f88ebbbfa4201d02d0fff14858beb89e98b474465c03104bb4c7a49dc5564fc60d446f185cf0cc9b8012e65d1fac483
diff --git a/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild b/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
new file mode 100644
index 000000000000..1d416dfca454
--- /dev/null
+++ b/media-gfx/autopano-sift-C/autopano-sift-C-2.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils versionator
+
+DESCRIPTION="SIFT algorithm for automatic panorama creation in C"
+HOMEPAGE="http://hugin.sourceforge.net/ http://user.cs.tu-berlin.de/~nowozin/autopano-sift/"
+SRC_URI="mirror://sourceforge/hugin/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-"$(get_version_component_range 1-3)"
+
+RDEPEND="!media-gfx/autopano-sift
+ dev-libs/libxml2
+ media-libs/libpano13:0=
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ sys-libs/zlib
+ virtual/jpeg:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-lm.patch
+ epatch_user
+}
diff --git a/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-lm.patch b/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-lm.patch
new file mode 100644
index 000000000000..97619975d9b6
--- /dev/null
+++ b/media-gfx/autopano-sift-C/files/autopano-sift-C-2.5.1-lm.patch
@@ -0,0 +1,14 @@
+Link against -lm (mathlib) because ScaleSpace.c (which is part of the internal libsift.a)
+is using the exp() function, see http://bugs.gentoo.org/472150
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -121,7 +121,7 @@
+
+ ADD_LIBRARY(libsift STATIC ${LIBSIFT_SOURCES})
+
+-set(all_libs libsift ${JPEG_LIBRARIES} ${TIFF_LIBRARIES}
++set(all_libs libsift m ${JPEG_LIBRARIES} ${TIFF_LIBRARIES}
+ ${PNG_LIBRARIES} ${ZLIB_LIBRARIES} ${PANO13_LIBRARIES} ${LIBXML2_LIBRARIES})
+
+ add_executable(generatekeys GenerateKeys.c)
diff --git a/media-gfx/autopano-sift-C/metadata.xml b/media-gfx/autopano-sift-C/metadata.xml
new file mode 100644
index 000000000000..239509055f5b
--- /dev/null
+++ b/media-gfx/autopano-sift-C/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <longdescription>autopano-sift-C is a program to automatically find control points
+ for stitching together panoramas.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">hugin</remote-id>
+ </upstream>
+</pkgmetadata>