summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/autotrace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/autotrace')
-rw-r--r--media-gfx/autotrace/Manifest2
-rw-r--r--media-gfx/autotrace/autotrace-0.31.1-r6.ebuild58
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-GetOnePixel.patch16
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-bool.patch12
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-libpng-1.5.patch64
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-libpng14.patch17
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-m4.patch7
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch13
-rw-r--r--media-gfx/autotrace/files/autotrace-0.31.1-swf-output.patch30
-rw-r--r--media-gfx/autotrace/metadata.xml6
10 files changed, 225 insertions, 0 deletions
diff --git a/media-gfx/autotrace/Manifest b/media-gfx/autotrace/Manifest
new file mode 100644
index 000000000000..a6c51613f1e0
--- /dev/null
+++ b/media-gfx/autotrace/Manifest
@@ -0,0 +1,2 @@
+DIST autotrace_0.31.1-15.diff.gz 343197 SHA256 d7084e992ef43db3dec5f912ba757c616b4698aeea17b9c167f2686c3f2df9c9 SHA512 70d3003120e2c0eb82c5f6dc7fd303eec2dcc772b81c22c3624bfa28bb5048016fd923a85f333904af326e201422bde05bed22fe7af5de939542e64b2883a7cb WHIRLPOOL c0c7f64c14aab41d56f3435c63ff40b1a1df51d69285192f2ef3532b03688aa13f120f1b9778ffa9fa9d2e97ab8bce2a229f49819177985e86ae8177f3225c72
+DIST autotrace_0.31.1.orig.tar.gz 362718 SHA256 5a1a923c3335dfd7cbcccb2bbd4cc3d68cafe7713686a2f46a1591ed8a92aff6 SHA512 7d0ec86a41617b3d4336eed72f2974c10f569ff53d450a4c91b4611bb6fdb8c4ff81d04d91e9d20f1b4df592f82c8421e7656af7fa2bdc786ffb4618e9eadd24 WHIRLPOOL 2fda99c453bf4a98ba85abf9853a06fdf8f6d49df5804d377ff4bb9131f21a202eb60749f39afa4ca258432c2ddef4d12e6edce14c69f42a25b26c56fb46fc3d
diff --git a/media-gfx/autotrace/autotrace-0.31.1-r6.ebuild b/media-gfx/autotrace/autotrace-0.31.1-r6.ebuild
new file mode 100644
index 000000000000..006e80d8fc7c
--- /dev/null
+++ b/media-gfx/autotrace/autotrace-0.31.1-r6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+_dpatch=15
+
+DESCRIPTION="A program for converting bitmaps to vector graphics"
+HOMEPAGE="http://packages.qa.debian.org/a/autotrace.html http://autotrace.sourceforge.net/"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/a/${PN}/${PN}_${PV}-${_dpatch}.diff.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+imagemagick static-libs"
+
+RDEPEND="media-libs/libexif:=
+ media-libs/libpng:0=
+ >=media-libs/ming-0.4.2:=
+ >=media-gfx/pstoedit-3.50:=
+ imagemagick? ( >=media-gfx/imagemagick-6.6.2.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${PV}-${_dpatch}.diff
+
+ epatch \
+ "${FILESDIR}"/${P}-{m4,libpng14,pkgconfig}.patch \
+ "${FILESDIR}"/${P}-swf-output.patch \
+ "${FILESDIR}"/${P}-GetOnePixel.patch \
+ "${FILESDIR}"/${P}-libpng-1.5.patch
+
+ # Fix building on PowerPC with Altivec
+ epatch "${FILESDIR}"/${P}-bool.patch
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die #468496
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with imagemagick magick) \
+ --with-ming \
+ --with-pstoedit
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-GetOnePixel.patch b/media-gfx/autotrace/files/autotrace-0.31.1-GetOnePixel.patch
new file mode 100644
index 000000000000..048b7a76be70
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-GetOnePixel.patch
@@ -0,0 +1,16 @@
+http://cvs.fedoraproject.org/viewvc/rpms/autotrace/devel/autotrace-0.31.1-GetOnePixel.patch?view=markup
+
+--- input-magick.c
++++ input-magick.c
+@@ -83,7 +83,11 @@
+
+ for(j=0,runcount=0,point=0;j<image->rows;j++)
+ for(i=0;i<image->columns;i++) {
++#if (MagickLibVersion < 0x0645) || (MagickLibVersion >= 0x0649)
+ p=GetOnePixel(image,i,j);
++#else
++ GetOnePixel(image,i,j,pixel);
++#endif
+ AT_BITMAP_BITS(bitmap)[point++]=pixel->red; /* if gray: red=green=blue */
+ if(np==3) {
+ AT_BITMAP_BITS(bitmap)[point++]=pixel->green;
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-bool.patch b/media-gfx/autotrace/files/autotrace-0.31.1-bool.patch
new file mode 100644
index 000000000000..447f10c735ad
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-bool.patch
@@ -0,0 +1,12 @@
+--- types.h.old 2011-03-03 13:56:30.000000000 +0000
++++ types.h 2011-03-03 13:59:45.000000000 +0000
+@@ -25,6 +25,9 @@
+ #ifndef bool
+ typedef enum { false = 0, true = 1 } at_bool;
+ #else
++#ifdef __ALTIVEC__
++#include <stdbool.h>
++#endif
+ #define at_bool bool
+ #endif
+ #else
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-libpng-1.5.patch b/media-gfx/autotrace/files/autotrace-0.31.1-libpng-1.5.patch
new file mode 100644
index 000000000000..7252b79aaf1a
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-libpng-1.5.patch
@@ -0,0 +1,64 @@
+http://sourceforge.net/mailarchive/forum.php?thread_name=01e601cbc22e%24f45d7200%24dd185600%24%40acm.org&forum_name=png-mng-implement
+
+$NetBSD$
+
+Fix build with png-1.5.
+
+--- input-png.c.orig 2002-10-10 20:44:14.000000000 +0000
++++ input-png.c
+@@ -42,17 +42,17 @@ static png_bytep * read_png(png_structp
+
+ static void handle_warning(png_structp png, const at_string message) {
+ LOG1("PNG warning: %s", message);
+- at_exception_warning((at_exception_type *)png->error_ptr,
++ at_exception_warning((at_exception_type *)png_get_error_ptr(png),
+ message);
+- /* at_exception_fatal((at_exception_type *)at_png->error_ptr,
++ /* at_exception_fatal((at_exception_type *)png_get_error_ptr(at_png),
+ "PNG warning"); */
+ }
+
+ static void handle_error(png_structp png, const at_string message) {
+ LOG1("PNG error: %s", message);
+- at_exception_fatal((at_exception_type *)png->error_ptr,
++ at_exception_fatal((at_exception_type *)png_get_error_ptr(png),
+ message);
+- /* at_exception_fatal((at_exception_type *)at_png->error_ptr,
++ /* at_exception_fatal((at_exception_type *)png_get_error_ptr(at_png),
+ "PNG error"); */
+
+ }
+@@ -157,8 +157,8 @@ read_png(png_structp png_ptr, png_infop
+
+ png_set_strip_16(png_ptr);
+ png_set_packing(png_ptr);
+- if ((png_ptr->bit_depth < 8) ||
+- (png_ptr->color_type == PNG_COLOR_TYPE_PALETTE) ||
++ if ((png_get_bit_depth(png_ptr, info_ptr) < 8) ||
++ (png_get_color_type(png_ptr, info_ptr) == PNG_COLOR_TYPE_PALETTE) ||
+ (png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS)))
+ png_set_expand(png_ptr);
+
+@@ -181,20 +181,10 @@ read_png(png_structp png_ptr, png_infop
+ PNG_BACKGROUND_GAMMA_FILE, 1, 1.0);
+ } else
+ png_set_strip_alpha(png_ptr);
++ png_set_interlace_handling(png_ptr);
+ png_read_update_info(png_ptr, info_ptr);
+
+-
+- info_ptr->row_pointers = (png_bytepp)png_malloc(png_ptr,
+- info_ptr->height * sizeof(png_bytep));
+-#ifdef PNG_FREE_ME_SUPPORTED
+- info_ptr->free_me |= PNG_FREE_ROWS;
+-#endif
+- for (row = 0; row < (int)info_ptr->height; row++)
+- info_ptr->row_pointers[row] = (png_bytep)png_malloc(png_ptr,
+- png_get_rowbytes(png_ptr, info_ptr));
+-
+- png_read_image(png_ptr, info_ptr->row_pointers);
+- info_ptr->valid |= PNG_INFO_IDAT;
++ png_read_png(png_ptr, info_ptr, PNG_TRANSFORM_IDENTITY, NULL);
+ png_read_end(png_ptr, info_ptr);
+ return png_get_rows(png_ptr, info_ptr);
+ }
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-libpng14.patch b/media-gfx/autotrace/files/autotrace-0.31.1-libpng14.patch
new file mode 100644
index 000000000000..72f76bcf1535
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-libpng14.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/321525
+
+--- configure.in
++++ configure.in
+@@ -188,9 +188,9 @@
+ HAVE_LIBPNG=yes ,,-lz -lm)
+ if test "x$HAVE_LIBPNG" = "xyes" ; then
+ LIBPNG_LDFLAGS="-lpng -lz -lm"
+- PKGCONFIG_REQS="$PKGCONFIG_REQS, libpng12"
+- if pkg-config --exists libpng12 ; then
+- LIBPNG_LDFLAGS="`pkg-config --libs libpng12`"
++ PKGCONFIG_REQS="$PKGCONFIG_REQS, libpng"
++ if pkg-config --exists libpng ; then
++ LIBPNG_LDFLAGS="`pkg-config --libs libpng`"
+ fi
+ AC_SUBST(LIBPNG_LDFLAGS)
+ AC_DEFINE(HAVE_LIBPNG)
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-m4.patch b/media-gfx/autotrace/files/autotrace-0.31.1-m4.patch
new file mode 100644
index 000000000000..7781be784f01
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-m4.patch
@@ -0,0 +1,7 @@
+--- autotrace.m4
++++ autotrace.m4
+@@ -6,3 +6,3 @@
+ dnl
+-AC_DEFUN(AM_PATH_AUTOTRACE,
++AC_DEFUN([AM_PATH_AUTOTRACE],
+ [dnl
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch b/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch
new file mode 100644
index 000000000000..a6371dd3c725
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-pkgconfig.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/283534
+
+--- configure.in
++++ configure.in
+@@ -223,7 +223,7 @@ if test "${swf_header_found}" = yes ; then
+ AC_CHECK_LIB(ming, Ming_init,
+ HAVE_LIBSWF=yes,,-lm)
+ if test "$HAVE_LIBSWF" = "yes" ; then
+- PKGCONFIG_REQS="$PKGCONFIG_REQS, ming"
++ PKGCONFIG_REQS="$PKGCONFIG_REQS, libming"
+ LIBSWF_LDFLAGS="-lming -lm"
+ AC_SUBST(LIBSWF_LDFLAGS)
+ AC_DEFINE(HAVE_LIBSWF)
diff --git a/media-gfx/autotrace/files/autotrace-0.31.1-swf-output.patch b/media-gfx/autotrace/files/autotrace-0.31.1-swf-output.patch
new file mode 100644
index 000000000000..b9132c2ac529
--- /dev/null
+++ b/media-gfx/autotrace/files/autotrace-0.31.1-swf-output.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/122035
+
+--- output-swf.c
++++ output-swf.c
+@@ -24,7 +24,6 @@
+ #include "spline.h"
+ #include "color.h"
+ #include "output-swf.h"
+-#include <ming.h>
+
+ #define FPS 24.0
+ #define IMGID 1
+
+--- output-swf.h
++++ output-swf.h
+@@ -23,6 +23,7 @@
+ #define OUTPUTSWF_H
+
+ #include "output.h"
++#include <ming.h>
+
+ int output_swf_writer(FILE* file, at_string name,
+ int llx, int lly, int urx, int ury,
+@@ -31,4 +32,6 @@
+ at_msg_func msg_func,
+ at_address msg_data);
+
++void fileOutputMethod(byte b, void *data);
++
+ #endif /* Not def: OUTPUTSWF_H */
diff --git a/media-gfx/autotrace/metadata.xml b/media-gfx/autotrace/metadata.xml
new file mode 100644
index 000000000000..08a29587f786
--- /dev/null
+++ b/media-gfx/autotrace/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+<herd>fonts</herd>
+</pkgmetadata>