summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-01 03:14:01 +0000
committerSam James <sam@gentoo.org>2020-11-01 03:14:08 +0000
commit31b8c1b407969b492d514cc694edaf1d497344e9 (patch)
tree59d915b1d3a11e23cf1ceb9e521766ef50880799 /media-gfx/cellwriter
parentnet-wireless/blueman: Stabilize 2.1.4 amd64, #751556 (diff)
downloadgentoo-31b8c1b407969b492d514cc694edaf1d497344e9.tar.gz
gentoo-31b8c1b407969b492d514cc694edaf1d497344e9.tar.bz2
gentoo-31b8c1b407969b492d514cc694edaf1d497344e9.zip
media-gfx/cellwriter: fix build with gcc 10
Bug: https://bugs.gentoo.org/707182 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/cellwriter')
-rw-r--r--media-gfx/cellwriter/cellwriter-1.3.6.ebuild17
-rw-r--r--media-gfx/cellwriter/files/cellwriter-1.3.6-fno-common.patch25
2 files changed, 34 insertions, 8 deletions
diff --git a/media-gfx/cellwriter/cellwriter-1.3.6.ebuild b/media-gfx/cellwriter/cellwriter-1.3.6.ebuild
index 467dc084c967..d7a4e31afd01 100644
--- a/media-gfx/cellwriter/cellwriter-1.3.6.ebuild
+++ b/media-gfx/cellwriter/cellwriter-1.3.6.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-inherit xdg-utils
+EAPI=7
+
+inherit xdg
DESCRIPTION="Grid-entry natural handwriting input panel"
HOMEPAGE="http://risujin.org/cellwriter/"
@@ -11,22 +12,22 @@ SRC_URI="https://github.com/risujin/cellwriter/archive/${PV}.tar.gz -> ${P}.tar.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+BDEPEND="virtual/pkgconfig"
RDEPEND="x11-libs/gtk+:2
x11-libs/libX11
x11-libs/libXtst"
DEPEND="${RDEPEND}
- virtual/pkgconfig
x11-base/xorg-proto"
DOCS="AUTHORS ChangeLog README TODO" # NEWS is no-op
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.6-fno-common.patch"
+)
+
src_prepare() {
default
sed -i -e '/Encoding/d' ${PN}.desktop || die
}
-
-pkg_postinst() { xdg_icon_cache_update; }
-pkg_postrm() { xdg_icon_cache_update; }
diff --git a/media-gfx/cellwriter/files/cellwriter-1.3.6-fno-common.patch b/media-gfx/cellwriter/files/cellwriter-1.3.6-fno-common.patch
new file mode 100644
index 000000000000..54f035339720
--- /dev/null
+++ b/media-gfx/cellwriter/files/cellwriter-1.3.6-fno-common.patch
@@ -0,0 +1,25 @@
+https://sources.debian.org/patches/cellwriter/1.3.6-2/fix_ftbfs.patch/
+https://bugs.gentoo.org/707182
+--- a/src/options.c
++++ b/src/options.c
+@@ -26,9 +26,6 @@ Foundation, Inc., 51 Franklin Street, Fi
+ #include <stdlib.h>
+ #include <string.h>
+
+-/* preprocess.c */
+-int ignore_stroke_dir, ignore_stroke_num;
+-
+ /* cellwidget.c */
+ extern int cell_width, cell_height, cell_cols_pref, cell_rows_pref,
+ train_on_input, right_to_left, keyboard_enabled, xinput_enabled;
+--- a/src/recognize.c
++++ b/src/recognize.c
+@@ -29,7 +29,7 @@ Foundation, Inc., 51 Franklin Street, Fi
+ #include "recognize.h"
+
+ /* preprocess.c */
+-int prep_examined;
++extern int prep_examined;
+
+ void engine_prep(void);
+