summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-04-12 09:36:45 -0600
committerTim Harder <radhermit@gentoo.org>2020-04-12 09:48:42 -0600
commit829cde6f4d7b6239c6e871af41dda04e02b46d0f (patch)
treeaf4066a82926110e61e150f8560b480cfa9b23b3 /media-gfx/chafa
parentmedia-gfx/feh: version bump to 3.4 (diff)
downloadgentoo-829cde6f4d7b6239c6e871af41dda04e02b46d0f.tar.gz
gentoo-829cde6f4d7b6239c6e871af41dda04e02b46d0f.tar.bz2
gentoo-829cde6f4d7b6239c6e871af41dda04e02b46d0f.zip
media-gfx/chafa: version bump to 1.4.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-gfx/chafa')
-rw-r--r--media-gfx/chafa/Manifest1
-rw-r--r--media-gfx/chafa/chafa-1.4.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/chafa/Manifest b/media-gfx/chafa/Manifest
index 1452b260e4c1..c08f95306eac 100644
--- a/media-gfx/chafa/Manifest
+++ b/media-gfx/chafa/Manifest
@@ -1,2 +1,3 @@
DIST chafa-1.2.1.tar.xz 354784 BLAKE2B a37561506edd1117093ad8d2543e8d8779a5edb346d6277baf31a15dabb1f5279234a36822d7f4225bb75ea6f75ff67966b1be832e90e5da03a02b6f140ab576 SHA512 71aee87618961a5910b9bb7a76b50df6f78df3621adc3ea7c462ba26df0147f0cb32f428fb7f6e5dc26968ee9bd3ee902762a7cb8735d1c51fd0ebd107c4226e
DIST chafa-1.4.0.tar.xz 388932 BLAKE2B 0ccaae1495bd410b05d291ebcf2b6266374f013536ec1b953d6127e63c20b11ff78e96772309caeb5c4bbfc40729f60291b0ab3d2395824801aec7763c1ac2b3 SHA512 e464750296db0eca5d718ff70dbb51529abcd4ff3d5bdd15f20f10ff0207f282e8b59799476fc05718efb48b81b331ae1518d450efd6b62b98a41049e1c6e9d5
+DIST chafa-1.4.1.tar.xz 389428 BLAKE2B 8ed6c6d57953d784763f10c274bd8b7acf7857b095bae58c476d2e17418a7112f1ec000d667eebfc2eda712c9588e686ad4021da017f4d187a5461c0435c5476 SHA512 f0bd1911fd544f93afadbb2105f151dc77e31a2f3af4c7f8441a06f547a7ebe0674664721b18c3a35a7c4e745dda666713adc1dfbe5e97dfdc54856a13bd5063
diff --git a/media-gfx/chafa/chafa-1.4.1.ebuild b/media-gfx/chafa/chafa-1.4.1.ebuild
new file mode 100644
index 000000000000..c17b462fcc51
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs +tools"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/imagemagick:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local econfargs=(
+ $(use_enable static-libs static)
+ # install manpage manually
+ --disable-man
+ $(use_with tools)
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README TODO )
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}"/usr/lib* -name '*.la' -delete || die
+}