summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-10 15:17:01 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-02-13 22:08:55 +0100
commitd9e05b5bafb91e64c8b1e525fe93ffc6d093f3d9 (patch)
treee53678aa3da4fcbcb226b377babbf3e9daa45d5b /media-gfx/chafa
parentapp-arch/engrampa: add missing optfeature inherit (diff)
downloadgentoo-d9e05b5bafb91e64c8b1e525fe93ffc6d093f3d9.tar.gz
gentoo-d9e05b5bafb91e64c8b1e525fe93ffc6d093f3d9.tar.bz2
gentoo-d9e05b5bafb91e64c8b1e525fe93ffc6d093f3d9.zip
media-gfx/chafa: Bump to 1.6.0
Closes: https://github.com/gentoo/gentoo/pull/19403 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-gfx/chafa')
-rw-r--r--media-gfx/chafa/Manifest1
-rw-r--r--media-gfx/chafa/chafa-1.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-gfx/chafa/Manifest b/media-gfx/chafa/Manifest
index c8d6ff58a27a..bcce16cf5d3d 100644
--- a/media-gfx/chafa/Manifest
+++ b/media-gfx/chafa/Manifest
@@ -1 +1,2 @@
DIST chafa-1.4.1.tar.xz 389428 BLAKE2B 8ed6c6d57953d784763f10c274bd8b7acf7857b095bae58c476d2e17418a7112f1ec000d667eebfc2eda712c9588e686ad4021da017f4d187a5461c0435c5476 SHA512 f0bd1911fd544f93afadbb2105f151dc77e31a2f3af4c7f8441a06f547a7ebe0674664721b18c3a35a7c4e745dda666713adc1dfbe5e97dfdc54856a13bd5063
+DIST chafa-1.6.0.tar.xz 417888 BLAKE2B f9837a9062396f92974088ea2e59e050089b462442ac01af17dc7f47f4c3a24542facd4c977cac2ee9db3c4af9bae2349cea9186f9d0362cf7bb74f4e83d345b SHA512 47843b8bf1b0555ae3570f688229e9f848e2e30c80aa277278230196f6fdb583b7f9170d1740171f2f4c5d5d915e00df407722067bcf6f2dc888804b7bd074da
diff --git a/media-gfx/chafa/chafa-1.6.0.ebuild b/media-gfx/chafa/chafa-1.6.0.ebuild
new file mode 100644
index 000000000000..2c7e6798a528
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+tools"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/imagemagick:0=
+ tools? ( >=media-libs/freetype-2.0.0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-man \
+ $(use_with tools)
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README TODO )
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}" -name '*.la' -delete || die
+}